Start a new topic

Received the Orba, wont turn on after firmware update

The Orba arrived this morning, I was able to play with it for a bit before downloading the IOS app and being told to update the firmware. I did and after it completed the Orba will no longer turn on. 

8 people have this problem

Could you try to connect Orba to a Mac or Windows PC using a USB cable and open the Orba app, click on the "A" in the upper right corner to open the settings, and click on the cloud symbol while holding down the shift key on your computer keyboard and wait for the update to complete? If the firmware update got stuck for some reason this should complete the update.


If this does not work please let our customer service know so that they can help resolve this.

3 people like this

THANK YOU! Shift-clicking the firmware icon worked. 

2 people like this

i've also been trying this and does not work. please help!!!

update: i switch usb ports and it was able to update. now is working.

1 person likes this
Great to hear!

I've tried several different USB ports, still no luck.  The program immediately says "There was an error updating".

7 people like this

Possibly a longshot (I think the issue behind this has since been fixed), but in the Orba app, check the firmware version number from the Artiphon logo at top right. If it says 0.13.19, the firmware has actually updated successfully and the error is the report that it hasn't.

1 person likes this

I think the updater is 0.14.9, but the Orba itself is dark - no lights, no sound, no external indications of life at all.  The only thing telling me there's anybody home at all is that the computer still beeps when I plug the Orba in.  I haven't been able to spot it in the device list, but Windows does recognize that a device has been connected.

So far... just "An error occurred during the firmware update."  I count myself lucky if I see "Updating.  Talk among yourselves." for more than a split second.

4 people like this

I submitted a ticket before my account was created and I saw this discussion.

On my Mac, the app (version 0.14.9)  itself is unstable, crashing each time I try to quit, irrespective of whether the Orba is connected or not. In fact, it would not recognize the Orba at all until I did a restart earlier, which only seemed to connect once. Right after that, I promptly began the firmware update, which then resulted in a failure error, and since, the Orba has been completely unresponsive. 

Holding shift seems to implement a firmware process for a few seconds still, yet followed by the error that the firmware update fails. This then is followed by the desktop app crashing when I try to quit it. I tried multiple ports and different cables to be sure. 

FWIW, I first played with the Orba last night, followed by an attempt to get it to connect to my iPad Pro. Only a synth app recognized the incoming signal: it never was recognized via the system iOS settings, as was the same issue with my Mac (OS) this morning. Hence I went looking for updates.

Attached is a composite of the two different experiences I have been seeing this morning, in addition to the now bricked (dead) Orba device. 

1 person likes this

If it adds any more information, I dug out some utilities.  When I connect the Orba, I see an STMicro device in DFU mode connect.

It looks like the updater managed to render the darn thing completely lobotomized all the way back to "Hi I'm an STMicro STM32!  Program me!"  x.x  I hope the support team can get me back up and going without an RMA.

1 person likes this

I've sometimes seen that message after the Orba has updated successfully – but not if it's gone dark. A reset while connected to power (press & hold power & volume-up buttons together for five seconds) has always managed to bring it back to life for me, but that was under older firmware and I haven't had the issue with the current version. I notice the Orba manual now says the reset action is "hold power and volume down for five seconds", which may mean either "hold down power and volume" or hold power and volume-down" – it might be worth trying it that way as well while you're waiting for someone who actually knows what they're talking about to get back to you.

Incidentally, Arne's screenshot above shows him running app version 0.14.11, but the current release is indeed 0.14.9 (and the firmware 0.13.19 as shown), so you're definitely on the right version.

I should have mentioned that I tried various combinations of holding power/volume to try and reset, per both the manual, and then after seeing Nick's input. 

1 person likes this

Hmm. I'm stumped, but this does sound like an issue to which someone from Artiphon will have an answer when they're able to catch breath. I expect they're already on this, but it would be good to have a Troubleshooting section in the FAQs for issues like this that seem to be encountered by multiple users, even (or particularly) if the fix is a simple one.

1 person likes this

My orba app closed while it was performing a firmware update and now my orba will not light up either.  I do hear the windows chime when connecting it to the computer, but it wont turn on.  I've tried the suggested Shift+Click firmware update but it just keeps saying "and error has occured".

8 people like this
Login or Signup to post a comment