Start a new topic

Received the Orba, wont turn on after firmware update

The Orba arrived this morning, I was able to play with it for a bit before downloading the IOS app and being told to update the firmware. I did and after it completed the Orba will no longer turn on. 


7 people have this problem

Hi @Edo, welcome to the thread.  You'll definitely want to read the other four pages.  We've covered most of that already.  Many modern computers don't even have a USB 2.0 port anymore, but I already tried that too.  Pretty much, if it's been mentioned in this thread, all five pages of it, we've all tried it to the extent that we're capable.

I find it very frustrating the instructions and web site strongly urged everyone to do a firmware update ASAP, which is pretty much what got most of us into this predicament, and I'm sure will lead many more people down the path of having a very strong distrust of firmware updates in the future.  As an embedded software engineer I can tell you that's the last attitude any of us want to engender in the general public.

At this point, we're all just waiting for Artiphon to come back with a procedure that brings our current favorite musical instrument back from DFU mode.


1 person likes this

heya Michael. I understand..I would be frustrated too especially after all the delays in receiving this product....then you finally get it...and you get this. Selfishly,  I hope if mine finally comes I wont have to read this thread :) Its been stuck in Cali for days now, so I found a new Roli Lightpad Block on the real cheap to keep me nicely musically occupied in the mean time. g luck.


1 person likes this

Seems like a common thread in the successful recoveries by Will and Gary above is that if you're on a Mac, do the firmware update before updating the desktop app to the newer version.  Think I'll uninstall it and roll back to the older one before my Orba arrives (soon, it's with my local carrier).


Arne, is there something different with the FW updater code in the new version of the desktop app that could be causing the issue? 

Hi - in case it helps I want to mention that I have windows10 and Norton 360 and Norton was stopping mine from updating. Once I told it to let the update happen it worked beautifully. Hope this helps. There is a picture of the screen from norton that I posted earlier when I was having troubles you can look up as well. Thank you!
Brian, there is nothing changed in updater between versions 0.14.6 and 0.14.8 so I would not expect that to be the cause of any different behavior.

2 people like this

In fact, I removed version 0.14.8 from my machine and installed 0.14.6. Same results.


1 person likes this
A few minutes ago I received an email from Artiphon support. Attached to it was a firmware file for the Orba. Following their instructions I successfully installed it on my Orba. It is now up and running. I am one very happy Orba user again.

3 people like this

I just checked my email and they had sent me a local update file that worked beautifully.  My Orba is back up and running.  Thanks Jeremy @ Artiphon you've made my day!


2 people like this

Kenneth-san, 


Which desktop version have you used for local update file, 0.14.6 or 0.14.8?


I have just received prerelease version of FW update and tried to revive my Orba but it didn't work. 

As far as I have tried, Desktop app 0.14.6 doesn't accept dragging local FW fie on to cloud icon but 0.14.8 does. 


I have some brief report of results of my case to support team so that I am waiting for their prompt response so far. 

But i am curious about what is the difference between your success case and my fail. 


Best Regards, . 

This method fails in the following situations:

 

9 Sep 2020 3:19:51pm - Downloading Update Info

9 Sep 2020 3:19:51pm - Downloading Updater Utilities

9 Sep 2020 3:19:51pm - Downloading Updater Util - Capsense Bootloader

9 Sep 2020 3:19:51pm - Unable to find extracted utility - Capsense Bootloader

9 Sep 2020 3:19:51pm - Upload Failed

9 Sep 2020 3:19:51pm - Downloading Updater Util - ESP32

9 Sep 2020 3:19:52pm - Unable to find extracted utility - ESP32

9 Sep 2020 3:19:52pm - Upload Failed

9 Sep 2020 3:19:52pm - Downloading Updater Util - DFU

9 Sep 2020 3:19:52pm - Unable to find extracted utility - DFU

9 Sep 2020 3:19:52pm - Upload Failed

9 Sep 2020 3:19:52pm - Uploading Firmware

9 Sep 2020 3:19:52pm - Executing: C:\Users\ilove\AppData\Roaming\Artiphon\Orba\UpdateUtilities\dfu-util-win\dfu-util.exe -l

9 Sep 2020 3:19:52pm - Unable to update - Orba not connected

9 Sep 2020 3:19:52pm - Upload Failed


1 person likes this

The first download has not been completed. Is it due to fire wall?

Hey all! We've got a new approach to solving the issue of unresponsive Orbas. This should get your Orba up and running while we update the Windows app.

I've attached a file to this message that contains the current version of Orba's firmware. Once you've downloaded it, plug Orba back into your computer and drag this file on top of the Firmware Cloud icon in the settings of the desktop app. You shouldn't even need to unzip it. This will force a local firmware update as opposed to downloading the update from the cloud. Once updated, your Orba will exit DFU Mode and return to normal playing mode.

Note: if this doesn't work the first time, try holding the 'Power' button on Orba for a moment and attempting again. It's actually possible for Orba to turn on/off in DFU Mode, but because it's outwardly unresponsive you may not know if your device is on or not.

zip

4 people like this

Jeremy, 


Firstly, Thank you for your hard work to solve this Orba DFU issues.

However, I am sorry to tell you the solution you've show us above reply doesn't revive my Orba still.


I have tried drag update file two times as you instructed because first try failed. 

Then I pressed down power button for a while and did the same process. It failed again. 


Please refer to the screen shot files of log I've tried just now. 


Regards,

image

I tried to update my 'Orba'.

But, It's Failed.I captured screenshot.

@Jeremy,


Orba in DFU mode recognizes as STM Boot Loader in Device manager on Windows10.


The issue is that the default "inbox" driver that Windows uses for devices like this isn't set up for Generic USB access with libraries like "libusb."


https://www.hanselman.com/blog/HowToFixDfuutilSTMWinUSBZadigBootloadersAndOtherFirmwareFlashingIssuesOnWindows.aspx


(It would be need change STM32 BOOTLOADER driver to WinUSB driver by Zadig.

https://zadig.akeo.ie/)

Login or Signup to post a comment