Start a new topic

Orba as MIDI controller

A caveat if you are using your Orba as a MIDI controller: when I turned off the Orba onboard sounds in the app, I found that anything I played while using it as a MIDI controller (with PreSonus Studio One) would inexplicably stop after about two seconds--I couldn't play long sustained notes. I looked at the MIDI message traffic and it was sending a NoteOff message (telling Studio One to stop the instrument) after two seconds or so.


While I was submitting a ticket, I experimented a bit and realized that turning the onboard sounds back on in the app would allow it to work as expected, i.e. as long as I hold down the pad, it will keep sending the MIDI note.  You can simply turn the volume on the Orba all the way down and it will work as expected.


2 people like this idea

Interesting – is this over Bluetooth or a wired connection? I don't have Studio One, but I'm not seeing any rogue note-offs with anything I've tested on iOS or Mac; I only have an elderly pre-production unit used for betatesting, but I'm on the latest firmware and I'd surprised if a bug had arisen in the final hardware revision. Some things to try (that you've probably already thought of):

  1. Does it make any difference if you make the connection and then quit the Orba app? (You don't actually need it running if you're just using the Orba as a MIDI controller, unless you want to switch MIDI modes or otherwise tweak settings.)
  2. Could it be something to do with MIDI handling on Windows (if you're on Windows)? – the Instrument 1 app has to be closed on Windows before you can use the I1 with anything else.
  3. And does it make any difference switching between MPE, single channel, and channel-per-part?
(Apologies if this turns up twice – Freshdesk doesn't let you edit posts, so I had to delete the first version with its incomplete sentence under 1…)

Benjamin, thank you! You uncovered a bug. I can confirm, when "Orba Sounds" is set to "Off" in the app, random note-off messages are sent shortly after the note on, without having released the pad on Orba.  Thank you for the find, we are on it!

Until the fix is released- one workaround would be to turn down the speaker volume on Orba, assuming you are not using Orba as the USB speaker for your computer.

1 person likes this
It was in Windows 10, so plugged in with USB. Varying the MIDI mode did not change anything. I did have the app open for a while trying different things, but also tried with it closed. I was reading the MIDI traffic in Studio One and it was sending a NoteOff message. Very odd, but an easy workaround.

OK, I'm a dolt. Benjamin has indeed found a bug; I'd forgotten that I'd specifically set up my custom MIDI monitor to filter out note-offs from the readout. (If anyone with MidiFire on Mac or iOS has a use for an Orba-specific MIDI monitor, here it is attached – it's not elegant, but it does show you all the different messages in a window each so you can see what each gesture is doing. Sadly no use to Windows or Android users, though it might be possible to do something similar in Bome.)

mfr

1 person likes this

Incidentally, I don't think this has been publicised, but Artiphon have released a suite of presets to filter individual gestures for fine-tuning interaction with DAWs &c. – they're at the bottom of the Artiphon download page.


3 people like this

I got the Orba working with Orac 2.0 on the Organelle, Just be sure the Orba is plugged in and turned on before you boot up the Organelle and launch Orac.


Only weirdness I've encountered is on Windows 10 App and Driver Side is that the Orba wanted to be a USB Speaker and when that happened the Headphone jack of the Orba didn't seem to register that the Headphones were plugged in... ie. the sound was still coming out of the Orba's speaker.


Hoping we will eventually be able to selectively kill the Metronome while recording and maybe freely choose the MIDI Channels for each part.


1 person likes this

Thanks for posting the workaround. This was driving me nuts!

I'm wondering if someone could get me pointed in the right direction
on how to connect the Orba to Studio One 5?

I added a new instrument, clicked on all MIDI etc. I'm a newbie, but I dragged in an
instrument, and pressed on the orba, expecting something to record but it says in the
external devices, that it isn't seen.

I noticed that my computer started to use the Orba as a speaker, at one point.



1 person likes this

Could you assign Orba as a midi input device?


image


Here's what my device setting looks like in S1 (v5).


image


I don't think I changed anything from defaults.  It can be a little tricky to figure out which input device is sending what signals where in S1.  One thing to look for is which instrument the Orba is on (drum, bass, chord, lead) because that may send notes that aren't mapped to anything in the S1 instrument.

That all looks the same as what mine did. But I do see what you're saying about which instrument it is on. Do you have the Orba simply plugged into USB or do you plug it into an audio interface? I might simply have it incorrectly hooked up. Mine is just hooked in to the USB port.

I suggest you enable 'Enable MPE' if you have any mpe enabled instruments installed.  Thats the beauty of Orba to me....mpe... and Studio One v5 now supports mpe.  Hope this helps.

Well, I can add the device, I did check the MPE box," it doesn't indicate it is connected, but if I drag the Orba in as an
instrument, and pre-set the track to record, hit record, it records crazy waveforms, and numbers are
flashing aftertouch, control 113 etc. But hitting playback doesn't play anything.


I literally bought the DAW and other equipment, in hopes of teaching myself how to assign cool sounds to the Orba, like they did in the demos. I will definitely research myself, if someone knows what area I should read up on. I have tons of Studio One 4/5 videos I've watched and ready to watch more, so do you think I have it hooked up, due to the waveforms being recorded, but I have another setting wrong?

Login or Signup to post a comment