Start a new topic

Orba as MIDI controller

A caveat if you are using your Orba as a MIDI controller: when I turned off the Orba onboard sounds in the app, I found that anything I played while using it as a MIDI controller (with PreSonus Studio One) would inexplicably stop after about two seconds--I couldn't play long sustained notes. I looked at the MIDI message traffic and it was sending a NoteOff message (telling Studio One to stop the instrument) after two seconds or so.


While I was submitting a ticket, I experimented a bit and realized that turning the onboard sounds back on in the app would allow it to work as expected, i.e. as long as I hold down the pad, it will keep sending the MIDI note.  You can simply turn the volume on the Orba all the way down and it will work as expected.


4 people like this idea

Incidentally, I don't think this has been publicised, but Artiphon have released a suite of presets to filter individual gestures for fine-tuning interaction with DAWs &c. – they're at the bottom of the Artiphon download page.


3 people like this
Until the fix is released- one workaround would be to turn down the speaker volume on Orba, assuming you are not using Orba as the USB speaker for your computer.

2 people like this

I got the Orba working with Orac 2.0 on the Organelle, Just be sure the Orba is plugged in and turned on before you boot up the Organelle and launch Orac.


Only weirdness I've encountered is on Windows 10 App and Driver Side is that the Orba wanted to be a USB Speaker and when that happened the Headphone jack of the Orba didn't seem to register that the Headphones were plugged in... ie. the sound was still coming out of the Orba's speaker.


Hoping we will eventually be able to selectively kill the Metronome while recording and maybe freely choose the MIDI Channels for each part.


2 people like this

Benjamin, thank you! You uncovered a bug. I can confirm, when "Orba Sounds" is set to "Off" in the app, random note-off messages are sent shortly after the note on, without having released the pad on Orba.  Thank you for the find, we are on it!


1 person likes this

The fix will be in the next release. We can not commit to any timeline but this will be very soon.


1 person likes this

OK, I'm a dolt. Benjamin has indeed found a bug; I'd forgotten that I'd specifically set up my custom MIDI monitor to filter out note-offs from the readout. (If anyone with MidiFire on Mac or iOS has a use for an Orba-specific MIDI monitor, here it is attached – it's not elegant, but it does show you all the different messages in a window each so you can see what each gesture is doing. Sadly no use to Windows or Android users, though it might be possible to do something similar in Bome.)

mfr

1 person likes this

I'm wondering if someone could get me pointed in the right direction
on how to connect the Orba to Studio One 5?

I added a new instrument, clicked on all MIDI etc. I'm a newbie, but I dragged in an
instrument, and pressed on the orba, expecting something to record but it says in the
external devices, that it isn't seen.

I noticed that my computer started to use the Orba as a speaker, at one point.



1 person likes this

I've just discovered an anomaly. When using Orba as a midi controller with Reason, buttons 4,7,and 8
don't trigger anything on the Redrum Drum Computer, it's a bit of a pain as there are 10 drum/cymbal soundsand I can only use 5 of them
 Can anyone tell me how to assign the buttons to different sounds?


I still couldn't get it to work, so I started researching more. I watched this video,,...

https://youtu.be/Wc-SOxMVIkU

And that solved my problem! How Gregor (I think is his name), added the devices in. So I tried it
his way and BOOM sound was coming out of Studio One 5! I also realized, what everyone was talking about, when I turned off the Orba sounds in the app, then the notes would not hold for more than a couple seconds. So I turned the Orba down, and that worked until the patch comes out.

Thanks to those who supplied things to try. I just happened to watch the right video.

Doug

Interesting – is this over Bluetooth or a wired connection? I don't have Studio One, but I'm not seeing any rogue note-offs with anything I've tested on iOS or Mac; I only have an elderly pre-production unit used for betatesting, but I'm on the latest firmware and I'd surprised if a bug had arisen in the final hardware revision. Some things to try (that you've probably already thought of):

  1. Does it make any difference if you make the connection and then quit the Orba app? (You don't actually need it running if you're just using the Orba as a MIDI controller, unless you want to switch MIDI modes or otherwise tweak settings.)
  2. Could it be something to do with MIDI handling on Windows (if you're on Windows)? – the Instrument 1 app has to be closed on Windows before you can use the I1 with anything else.
  3. And does it make any difference switching between MPE, single channel, and channel-per-part?
(Apologies if this turns up twice – Freshdesk doesn't let you edit posts, so I had to delete the first version with its incomplete sentence under 1…)

Thanks for posting the workaround. This was driving me nuts!

It was in Windows 10, so plugged in with USB. Varying the MIDI mode did not change anything. I did have the app open for a while trying different things, but also tried with it closed. I was reading the MIDI traffic in Studio One and it was sending a NoteOff message. Very odd, but an easy workaround.

@Ben (OP), I'm also experiencing the NoteOff MIDI messages after about two seconds when Orba sounds are Off.  I'm using the workaround to have Orba sounds on with the volume on the Orba turned low.  @Arne, is there an ETA to ship a fix for this bug?  I'm on firmware 0.13.19, current as of Oct 21, 2020.

Will not connect to Bluetooth will not connect to laptop using USB orbe just acts as a speaker tride it on 3 devices phone laptop tablet only bought it today think I have wasted my money will it work on android or Windows 10 not happy app is rubbish
Login or Signup to post a comment