Start a new topic

Unresponsive Orba? Follow these steps

Follow this article for step-by-step instructions.

1 person likes this idea

Just carried out the updated steps supplied by Adam McHeffey to no avail, Orba remains dead. Updated email sent to It is a pretty paperweight

Also attempted the new process to no avail.  I'm not in complete brick mode as I can still play the base sounds, but am unable to do anything else as my PC recognizes it but the software doesn't.  

I carried out the new steps outlined by Adam McHeffey and when I got to the volume up and power procedure my device was again recognised as a USB device and the update worked. I do though still find it very frustrating that my support reqiuest went unanswered for six days. It seems the update procedure has not been fully worked through or tested because these errors seem to be common. However, glad it's finally working again

Tried another PC - worked than..

Oliver, the Bluetooth LE Midi connection works different from a normal Bluetooth connection and Windows 10 does not work with Bluetooth LE midi. If you are on a Mac the BT Midi connection is done from the Mac's Audio Midi Setup. The firmware update requires a USB connection.

Joshua, there are several issues going on that all look very similar. Some of these have been addressed with the latest Windows app version:

Some of the issues are customers pressing Volume Up (+) and power at the same time, which puts Orba in update mode (looks dead)- the fix for that is pressing Volume Down (-) and power for 15 seconds and then powering on.

Some issues were due to anti-virus software and permissions settings in Windows. We updated our code signing last week but some of these issues still remain, others are resolved.

In some cases Orba does not seem to connect properly to some USB hardware/Windows combination. It seems like these are mostly cases where customers try to connect to Windows 7. Orba requires Windows 10.

We are still working through these issues but it really depends on which issue is actually the case to know if it may be already fixed and worth a try.

I apologize if I missed this, but this is the first that I've seen it indicated that the software requires Windows 10. Like I stated, I could have missed this somehow but it would at least offer a possible reason for the ongoing issues in my case as I'm running Windows 7.

I can report a new mess..

with great anger i used my work laptop that runs win 10.

I successfully did a standard fw update.

The imac running 10.13.4 high sierra did not manage to do that.

ok fine i thought and went back to my IOS 14 ipad that did work with the orba BEFORE the fw update of the orba.

Tried to connect via Bluetooth and it still fails to do that..

So as of now I have an updated orba but still cannot connect to my ipad apps....

There is not much left to try as I can only restart the ipad and turn the Bluetooth off and on in the Preferences..

To make it clear: I open an app like strng App and try to connect to the orba that is visible but the connection fails...

What now?

thx to Nick for the Infos.

Unfortunatly that did not solve the issue.

As I have an older ipad running on 13.6.1 I can use the orba on that old one.

But before the FW upgrade trouble I could use the orba with my IOS 14 ipad as well!

I rebooted the IOS 14 ipad, I went into systempreferences and shutoff bluetooth, used the several methods, that Nick suggested but, no matter what App I want to use, the BT connect fails on IOS 14 but runs on IOS 13.x

As of now I got my IOS 14 Ipad to recognize the Orba again.

Here is what I did:

I reset all Settings. I did not loose any apps or docs.and the orba was immediatly available after the Ipad restart.

Before that I tried to only reset the network settings which did not help.

To summarize the whole thing:

The Mac with high sierra failed to do the fw update.

My Win 10 Laptop did the job without any problems. There was no need for the procedure that Adam suggested.

It looks from the screenshot as if your Orba isn't connected. Tap the Orba icon next to the Artiphon logo button at top right to bring up the Bluetooth device list, and then tap Artiphon Orba to connect.


Connected my Orba to another PC, I was able to reanimate it using the "Holding-Shift" method


Don't give up on it just yet; it sounds very much as if the charge simply ran down. How were you charging it for those three hours? Did the app show it as fully charged when you started using it? Try charging it off mains power rather than a computer, give it at least two hours, and check the charge in the app. After charging you might need to do the force-reboot thing (press & hold power and volume-down together for 10 seconds) to bring it out of its trance.

You'll need to contact Artiphon for that; I'm just another Orbaphile trying to help get you back up & running. It's very unlikely that your unit is actually faulty; most seemingly dead Orbas have so far turned out to be the result either of a run-down battery or a failed firmware update. To double-check, it was showing a green full charge in the app and/or all green lights lit on a power-button press-and-hold when you started playing? I ask because in my experience the Orba takes a long, long time to charge (MUCH more than three hours) from a computer; mains charging is faster but still takes a while. Mine has been sitting charging for the last four or five hours from my Mac mini and is still only lit to the fourth tab. And the power can drain surprisingly fast if it's left on. I'd still very strongly recommend leaving it to charge overnight as the next step and then doing a force restart again if it's not turning on.

(Sorry, single press on the power button, not press-and-hold, obviously – that's to turn it off.)

Login or Signup to post a comment