Start a new topic

Unresponsive Orba? Follow these steps

Follow this article for step-by-step instructions.

1 person likes this idea

Just after receiving the Orba I connected and updated the device without trouble.. used it for a couple of days and suddenly died and didn't get recognized by Windows anymore.. made my kid (birthday-present) not happy.
I connected the Orba to my Linux-based computer and at least gave some response (lsusb), "STMicroelectronics STM Device in DFU Mode", so at least I knew there was some life in this dead-looking device.
I decided to connect it using another USB-port on the Windows-machine, I believe I pushed vol+/power for 5 seconds and voila.. it connected and update (latest already was installed) went fine.

I think stuff like this should not happen, a brand new device completely dying like this is unacceptable, and this without some obvious, easy to use and functional hard-reset option makes it even worse.

Andrew Wraight's comment (page 4) helped me a lot by the way..

First update attempt resulted in the lights out and unresponsive. Tried all of the button pushing including the three arm method to no avail. The device appears to be not connected to the computer.

Putting the Orba into DFU mode (press - and power for 15 seconds) my Windows 10 computer saw it as "SMTP Bootloader". There was no driver identified to support this. Reinstalling the app didn't resolve the driver problem.

I left the device in DFU mode, installed the Orba app in my laptop, connected the Orba, drivers started to load, the lights came on, the app said it had detected the device in DFU mode and the firmware update started automatically. Now it works.

It appears that somehow the Bootloader driver isn't being installed in some installations to support DFU mode. This probably accounts for the firmware update failure as the app can't see the device without the driver. 

i have solve my problem and i would like to tell you how i make it. use another laptop. Trust me, it helps.

Thanks for sharing this, @Dark! We've seen this solution work as well.





1 de março de 2021 9:04:58 pm - Baixando informações de atualização
1 de março de 2021 9:04:59 pm - Baixando utilitários
de atualização 1 de março de 2021 9:04:59 pm - Downloading Updater Util - Capsense Bootloader
1 de março de 2021 21:05:01 - Baixando atualizador Util - ESP32
1 mar 2021 21:05:06 pm - Downloading Updater Util - DFU
1 mar 2021 21:05:09 pm - Upload Firmware
1 março 2021 21:05:09 pm - Executando: C: \ Users \ JORDÃO \ AppData \ Roaming \ Artiphon \ Orba \ UpdateUtilities \ dfu-util-win \ dfu-util.exe -l
1 de março de 2021 21h05:09 - Executando: C: \ Usuários \ JORDÃO \ AppData \ Roaming \ Artiphon \ Orba \ UpdateUtilities \ dfu-util -win \ OrbaDriverInstaller.exe --usealldevices --vid 0x0483 --pid 0xdf11 --noprompt
1 de março de 2021 21:05:09 - C: \ Users \ JORDÃO \ AppData \ Roaming \ Artiphon \ Orba \ UpdateUtilities \ dfu-util-win \ OrbaDriverInstaller.exe
1 de março de 2021 21:05:09 - Não foi possível atualizar - Orba não conectado em
1 de março de 2021 21h05min09s - Falha no upload

ORBA 014.34 / WINDOWS 10 64 BITS

This is a ridiculous solution but it worked for me.  Try doing it all over again on a DIFFERENT computer.  I know I could not believe it either.

1 person likes this

here's the correct way to solve bricked Orba.
I've used anoter PC, as somebody suggested as I couldn't do it on the first PC.
But maybe same PC will be ok after this steps too.

1. get your Orba after over a year of waiting
2. have it bricked in the first week of using :P totally no response, zero LEDs, no sound ;(
3. don't plug your orba to PC yet, install the 0.14.34 orba app
4. press and hold volume +, then press power button too. release buttons (LEDs won't light)
5. plug to the PC. turn on orba app
6. wait for some drivers to be installed (i had that step)

7. if the app says that you should update firmware, click the update button

8. orba will blink it's LEDs for the first time
9. unplug Orba fast

(you should be able to play sounds after this step, but I wanted to try to complete the firmware update
10. connect orba to PC again, open app, you will notice that your orba's battery is loading

11. shift + click on the firmware update button

12. talk amongst yourselves as reccomended :P

13. wait ~2 minutes

14. nailed it! ;)

15. keep your fingers crossed Artiphon will do something really soon to fix this, and that Orba won't get bricked again

16. keep your fingers crossed so that Artiphon will think of a LED blink pattern that could communicate some messages to the owner while pressing some physical buttons to do the hard reset or put the orba into this weird DFU mode.

@Jacob Bruner Hellooo!! Now it's working!! I did the same procedure on another computer and it worked !!

g'day all

I have myself TWO Orbas

tried updating the firmware on both of them using the laptop I originally used when I got them both.

Whaddya know!? got the not connected message, nothin', no luck, I thought Sh!t!

Sure enough, pulled out an old laptop I had stashed away, installed the Orba Windows app, all good!

So everyone, don't despair

Obviously the devs have fucked up somewhere between the last windows app update and the current one

If you guys (devs) cant figure it out in the short term, how about keeping things nice and simple, and workable

drop the current update, revert back to the last known working version ( for everyone), then give yourself a breather while you figure out where you fucked up


Thanks, technically we try to keep the language here compatible with all audiences. We are looking into this to see if it may be related to a fresh install vs older app libraries.

just a sidenote, when I was installing the current app, and drivers on my stored laptop, I did notice a couple of error messages flash by, but wasn't quick enough to pause the install, and said error messages

in fact, when I connected the first Orba, to update, got an error message saying "Firmware Update Failed" or something similar, and I thought, "oh no, here we go again"
but was all good, lights flashed in sequence, as they should, ended on the "Lets try something" message

so followed suite on the second Orba, no error messages this time, updated nicely

BTW, I have no issues connecting either of my Orbas to either Android or Apple devices, so somewhere along the line you guys have "dropped the baby" on the Windoze app


Got my Orba yesterday, can't connect to my phone or laptop.. recognizes Orba as USB speaker device or something.. driver issue? I hit shift +click on the firmware update in the Desktop App and it runs into a problem, can't get past this screen. My phone app says I need to update the firmware so I can't use it on my phone either! I don't have another device to try this on, just a laptop so now what??

Hi Troy. Just responded to your ticket about this. Let me know if you have any other questions. 

Frozen again…6 month wait. Frozen…sent back the old one, new one…updated and new one frozen again… Highly disappointed
Login or Signup to post a comment