Start a new topic

Orba app 0.14.21 is available

Orba app version 0.14.21 is now available. 

For iOS: The Apple App Store will have the latest version for download or updating. 

For Android: The Orba Android app is still in a public beta test phase due to connection issues. The beta test can be joined here:

For Mac and Windows: If you have the app already installed you will see a prompt to update from within the app. If you have not installed the app, it is available here:

What's new:

  • Enjoy new tunings! The Orba Diatonic tuning can be found in the Lead presets folder. Orba Open and Orba 7th can be found in the Chord presets folder. 

  • Orba will now put itself to bed. Leave Orba running for ten minutes and it will automatically power down. Feel free to disable this feature in the settings menu.

  • The app will now automatically detect if your Orba is in "DFU mode” and prompt a firmware update. In the unlikely event that your Orba becomes unresponsive or "bricked," this will make it easy to resurrect. 

  • We’re temporarily removing the Song Browser and song saving buttons. Song saving was causing unexpected behavior in other areas. This is a temporary fix and we look forward to bringing songs back, better than before. 

  • This update also includes major stability improvement across multiple devices. 

4 people like this idea

Thanks Arne, the iOS bug  explains it.

Claudia, could you double check the current firmware version in settings page (press A on top right, firmware version is displayed on the bottom left) to see if it is 0.13.19? And the app version as well? (Should be 0.14.21) There were some issues with a dialog popping up asking to update when everything was up to date. The latest app version should have fixed that- maybe not entirely.

Arne, Firmware Version 0.13.10   App version 0.14.21, and just like Cris's the firmware update is grayed out. On my MacBook 

Arne, I just realized, it's the app on the Mac that's getting updated, not the firmware on the Orba. Right? But I don't have the new "feather" option under Browse and the Orba doesn't shut down after a few minutes. I'm missing something! I think!!

I just tried a wired connection to my Mac, and that brought back to my attention that KEY CHANGE is bundled in with SONGS.  So I'm stuck in D Major until Songs comes back.  Arne, what are the chances of you separating the two things?  I'm not hugely interested in recording on Orba, just using it as an alternative input device to other apps - I can be playing guitar or bass on stage as usual, and in a quiet section I can pick up the Orba in Chords mode and play some nice background strings via Logic/Mainstage.  Not now - absolutely no way of changing key... a method of doing so on the device would be the best option as has been discussed elsewhere on the forum.

Can you provide a download of the previous version of the desktop app in the meantime while you're fixing Songs, or is it coming back in a matter of days?

You can still change the tempo and key by clicking on the song edit pencil symbol in the top bar.

Arne, got it. Holding down Shift and clicking firmware update worked, I now have 0.13.19

Thanks Arne. It didn’t seem to stick. I’ll give it another try.

Holding the shift key worked for me as well, thanks Arne, I’ll remember that for the next round of updates. 

I was able to UPDATE or install Orba 0.14.22 on Android 11 Pixel 3a but not on Android 9 Amazon Fire HD 10 (9th gen) that was modified to accept Play Store apps.

I only get 0.14.21 despite removing and trying again.

I like the USB-C to USB-C alternative to testing for now but Fire hangs if connected and looses Bluetooth connection otherwise.
This means I can only use my phone tethered to test or wife's Mac laptop to update.

I am still investigating Linux running Windows app with Q4Wine or as USB tethered Midi and audio device for

Otherwise, it looks good with pieces and communication improving daily !
Thanks for doing this so transparently !

Lee (now Senior Geek)
previously: Cool Games Network

alternately: Event Video Multimedia

Seriously? I just spent the last hour or more un-installing and re-installing trying to troubleshoot the missing song tab and save button and then finally find out that you just disabled it? Why didn't you put a button there that said "Dead Button"? 

I just got the Orba today and can't connect to iOS app. The either crashes or loses connection. 

I'd like a refund please. I'm not impressed. Long wait for delivery and now the apps -- both Mac OSX and iOS -- don't work. Wow. Frustrated.

Will the option to update firmware through the phone app or a linux app become a possibility? I would really like an Orba, but I don't use Windows or Mac and would still like to be able to update the firmware.

I can't change the key either. the key change is gone until songs come back i guess? it also says c major but is def in stuck major.  is there an eta on this? because -and not to be that guy- but orba is pretty much useless to me without the key change ability. 

Another two odd bugs in this firmware, both loop related. One time it just forgot to record the bass drum on a drum piece recording. The other the whole orba crashed and made a little BEEP when I was trying to record the 4th part of a loop. Needless to say, this firmware is still not stable
Sam, thanks for reporting this.
Login or Signup to post a comment