Start a new topic

Orba + iOS 14.2

Hi all! Just a quick heads up:

Updating to iOS 14.2 on your mobile device will block Bluetooth connections between Orba and the Orba app. We're working on a fix for this and will have an update available soon.

- Jeremy

5 people like this idea

I just received my Orba yesterday. I have to say that I'm disappointed. The first thing that I did was update the firmware. I'm not entirely sure that worked because it kept getting to a screen that said "an error occurred." However at some point I restarted both the Orba and the app on my Mac and the green download cloud icon was greyed out. Both my iPad and my iPhone are already on 14.1 (not 14.2) and the bluetooth connection to the Orba from the Orba app is basically unusable. I can initially connect, but it seems that if I do just one thing, ex. switch modes, changing instruments from the presets etc. the connection is lost. 

Is there still no word on a fix for this issue? I would really like to start using my Orba.
Todd, if you load the iOS 14.3 beta, Bluetooth is working again. Hopefully it stays that way when it gets released.
You've got to be kidding me. Option 1 is to revert to a less secure version of iOS, and option 2 is to use the untested version (beta)?
Unfortunately it's down to Apple, not Artiphon; they put out an update that broke BLE MIDI, not just on the Orba, but everywhere. They absolutely deserve to be shouted at. This was a huge ballsup, and the fact that a fix is around the corner doesn't excuse it.

1 person likes this
Yep those folks screaming I want my money back need to take a breath and try to understand the logistics of what has happened. Here’s my best effort at an analogy: Imagine you buy a Sandisk brand USB drive and plug it in to your PC/laptop, whatever brand computer that is. Let’s say it works fine for a while. Then, after updating the operating system of your computer thru the normal software update process, you discover that the Sandisk USB drive is no longer recognised. You think “bah! This darned Sandisk USB drive must be faulty! Damn Sandisk and all they stand for!” Then, it turns out that after they software update, *all* brands of USB drives are no longer recognised by the computer, no Lexars, no Kingstons, no nuthin. What’s the common element in each instance of a failure? Yes, it’s the software update pushed out by the computer manufacturer. There’s nothing that any of the makers of such USB devices could have done to prevent this, and once the update is out in the wild they are at the mercy of everyone’s automatic (or otherwise) predilection to keep their computers up to date. Hopefully you can see the analogy. If not, scour the forums of other manufacturers of iOS Bluetooth midi devices, and you’ll see the same frustration there. Btw, I updated via the beta program to iOS 14.3 and can confirm that the issue is fixed, and the Orba app works fine once again :). If you’re not ok with using the beta, that’s understandable, and I’m sure if you wait just a bit longer, the fix will be out on the stable 14.3 release. cheers, Ian

I've updated my iPad to ios 14.3 and everything seems to be working well. That update is now widely available for download, I believe.

I was excited to hear that the ios 14.3 is available. I upgraded my iphone mini, BUT... same result, it keeps disconnecting and not being able to reconnect! As a result I can't change the sounds over bluetooth. Super annoying! Are other people experiencing this? Did I receive a defective unit?

I just re-tried mine, and it wasn't working, but it started up again after I restarted my ipad ... it looks like there's still something a bit dodgy on the iOS end.

I can use the Orba app to control the Orba, and Garageband with Orba as a BLE MIDI controller.

I upgraded my iPad also. I've done a full reboot of both the phone and the iPad after the upgrade. The problem is not fixed on either device. The initial bluetooth connection is lost when I try to change the instrument sounds, and the instrument sounds are not changed. When I try to reconnect sometimes it connects, but mostly I get a spinner while the app says 'connecting' and then the spinner stops and it says 'not connected' or 'offline'  :(

On a positive note, I can control the recording and song settings from the ios devices now. I just can't do the instrument sound changes using the presets browser

Orba wouldn't connect to my iPhone – the Orba app on the phone couldn't see the Orba. I tried resetting the Orba per instructions, restarting the iPhone – no joy. 

Then I realized my iPhone was still at 14.2. It should have auto-updated to 14.3, but it hadn't done so. I manually updated to 14.3, and the Orba connects just fine.

1 person likes this
Login or Signup to post a comment