Start a new topic

Firmware update issue with Orba firmware 0.13.5 and app v0.14.34

We found an issue with Orba firmware 0.13.5, the version that is on many Orbas out of the box, and the Orba app. When connecting an Orba with firmware 0.13.5 the app crashes. We are working on a fix. In the meantime, there is a workaround:

If your app crashes when connecting to a PC or Mac via USB:

Turn Orba off

Press and hold the volume up (+) button

While holding the volume up (+) button, press the power button

Orba shows no LED's, that is normal

Connect Orba to a Mac or Windows computer using a USB cable

Open Orba app version 0.14.34  (available here: )

Wait for Orba app to show this screen:


Click "Update"

If that screen does not show up, go to the settings and click on the cloud symbol next to "firmware update" while holding the shift key:


If there is still an issue please contact

my update failed. and now the orba is unresponsive. The timeline was the following: - I installed the Mac desktop app - as soon as the orba was connected and turned on, the app would crash. - I tried the solution DFU mode solution above and the firmware update failed. currently my orba is unresponsive. - furthermore I already tried the 15 hold + 5 power on to reactive the normal mode but it was unsuccessful. attached the image of the message after the tentative firmware update. what should I do?

3 people like this

I had exactly the same issue as Marco, but on the Windows app. My Orba is now unresponsive, and the app keeps telling me it's updating, but it's been this way for hours. 

I had the same issue with the firmware update. Also, the Orba becoming non-responsive... However, I plugged it back into the computer and repeated the process. When the Orba became responsive with the "update" I unplugged the Orba and was able to play with it... At least I can play it for the time being until a fix is made. 

1 person likes this

After several attempts, I managed to get the firmware update, and now the app doesn't crash anymore. Everything is working fine, i'm just saddened to learn that the "save songs" option has been disabled.

Following this get the Orba bricked. Several attempts of repeating the update with no luck. But what actually helped and managed to get the Orba updated, was to unplug USB cable during the process, just when the leds on Orba started to blink.

same prob

me too

I've spent a lot of time trying the steps proposed, but didn't get it to work... For those who have an unresponsive Orba, disconnect USB and hold volume (-) and power button for 15 seconds for a hard reset.

windows 10.  I followed Otakar's instructions of unplugging usb when lights appeared on the orba, seemed to work but only halfway the Orba still wasnt working properly bluetooth via Iphone.  I plugged the orba back into usb on pc and it showed current firmware but phone wasnt showing firmware at all so I tried clicking the cloud in the Orba app holding the shift key like an earlier instruction and that finished the firmware update 100% working on pc and Iphone.

Hey all, if you're still experiencing issues after completing these steps, please open a support ticket with us so we can help get you back to making music again as soon as possible.

Confirmed what Lee says. The application on the phone did not connect, but this time I was able to perform the update normally and everything works properly!

Quite an unusual way to update though :)

Login or Signup to post a comment