Start a new topic

Orba 2 Hacking Knowledge Base


This forum is intended to share Orba 2 hacking tips amongst the Orba 2 community. NOTE: Please post facts that are well understood & useful. If you have theories to discuss, please start another forum and link to it here.

2 people like this idea

...I found what I was sent Dec 2022.

""When it's constantly trying to boot, that means it has corrupted firmware which can typically be remedied by reinstalling it.  A full reinstall can be done via the app.  I've attached the full firmware below that you can drag (still zipped) anywhere onto the settings page of the app.  This of course will need to be after the app has first recovered Orba 2. The other method is the one you already tried, where you can just drop the partial firmware (.bin file) onto the bootloader drive.

If you can get the firmware stable, I can send you the correct partition contents.  Otherwise, I can look into replacing the Orba 2 for you.""


I presume the app can't recover yours, but if you wait for it to stop looping you may see a partition containing this zip file, or its contents, which you could use to replace whatever's there.

Like I say, didn't work for me, but worth a go. Otherwise you can hopefully get a replacement.


@BJG145 - Thanks indeed for that file and the note about it and your other notes. I have had sight of those other partitions and I think I can access them again. (By the way had you noticed one is named ORBA2FALLBK which made me think there may still be a way of doing it.) I have seen similar symptoms as you.

I imagine I may have corrupted the bootloader, but I don't feel certain about that. I sort of think it boots then fails to find a viable system and restarts. After a while it goes into what I think is a download mode (not sure about that). I've found a system bin file I captured a while ago that I think may not be corrupted.

 For the moment I'm going to think of other things and come back to it tomorrow. 

But again, regardless of whether it works or not, many thanks, it's appreciated.

...yep, there seems to be a partition which acts as a bootloader, and another partition which acts as a fallback bootloader if the first one gets messed up. I seem to remember that I could still access those, but I lost access to a third one containing the data  which is only accessible by using some command after establishing a serial link to it AFAIK. With the loop mode that my one got into though, that command was no longer available. (Like I say, you can usually see the Orba listed in Device Manager on Windows, and without that, there's no known way top access the data partition.)

I think it was the data partition that was the problem with mine; I reckon it kept trying and failing to load an altered preset.   

Yes, that's consistent with what I have experienced. I didn't keep an eye on the Device Manager - I found that file Explorer is popping up or disappearing which pretty much tells me the same things.

Oh, the OrbaRelease zip file you posted seems to have the same set of files that I found in a hidden folder  on my computer. There's other stuff there that may interest you if you haven't already seen them yourself!

"Users>Public>Public Documents>Artiphon>Orba>UpdateUtilities>orbaFw"

Well, it's been no luck so far. I should have a new Orba to play with (assuming it works OK) arriving tomorrow.  I'll spend a bit of time setting it up with the presets I most want to use and do some recording I've had in mind. 

I'll have another go at recovering this one once I've cleared my head again.

Had either of you ever tried leaving it on until the battery dies? Maybe if the battery dies and then is charged it will act differently? Not likely but worth a try.

Thought of it, hadn't quite to the point of trying it. The problem with the fixes so seems to be that the app only connects to the update partition when you try to and rewrite the zips or bin files (and/or it rejects them) and does nothing. The silver lining would be it'll helpful for sunning down the battery!

I will try and see if I can find a way to get to other partitions - but don't hold much hope so the battery thing  might have to be tried I think.

You guys are more techy than me - you might find those hidden files may hold info you can use more than I ever could.

Incidently I've just thought of an approach to programming looping that would offer flexibility for time signatures - not for the Orba, but I think it's a neat idea. 

It has occurred to me that perhaps the problem with these attempts to fix it might fail because Windows will not deal with partitions with whatever file system they are in. (As I'm sure you're aware people often complain they can't see data on USB drives which have been formatted on other devices.) That begs the question whether it might be possible to copy the needed files to the right place using Linux (or BSD). I don't have anything running Linux and I'm not sure I've got a machine I could run it on. Could try running a USB live version and see if the partitions are visible at least. (I suspect the Update partition may be created temporarily and disappears when the Orba is not in an Update mode though.)

Basically, from a looping state, two partitions are accessible to Windows. (You can get to the main boot partition by letting the loop time out, and you can get to the fallback boot partition by  wiping the main boot partition.)

There's also a third one that's also accessible to Windows using a hack, but not while it's looping...and that's the one where the problem lies. That's the one with the definition of the rogue failed preset that causes it to reset. That's my theory. I no longer have mine, I sent it back to Gear4Music for (unsuccessful) repair, but I don't think running the battery down will help because as soon as it comes back online again it'll still be tryintg to load the same dodgy preset from solid state memory in the inaccessible third partition.

It's had it.

Stubbornly I'm not convinced the problem lies in the partition (if that's what it is) where the user presets etc. are stored. A bad preset either doesn't show up on the Orba or if it does, only causes a problem when one attempts to play it. But it's almost impossible to tell where the problem is. I wonder whether my experiments have caused the system to write or otherwise  corrupt data elsewhere. But I accept that my Orba has probably had it and I don't really hold hope to save it. I still have one or two ideas to try but with no good expectations.

Having got hold of a B stock Orba now - I've been alerted to an important issue - just as Gear4Music couldn't repair your Orba, retailers aren't in a position to reset a returned product - they should be able to do this, Artiphon should be able to provide retailers the means to do it (and have something similar to help end users with). There's a customer privacy issue here, my new acquisition came with presets the previous owner had made sampling his own voice. They shouldn't be there - they weren't, but they could have had, offensive content. And that's another important issue - especially for something that might be bought for the use of young people.

Having worked in a related retailer area I'd be really unhappy dealing with a company that potentially puts me in that sort of problem. Apart from the fact that I came to feel that any product that got returned wasn't worth having sold in the first place. 

The "new" Orba seems to be fine, so that's a positive at least and it will be treated more gently!

"A bad preset either doesn't show up on the Orba or if it does, only causes a problem when one attempts to play it."

It causes a problem when the Orba tries to load it from flash storage into RAM; 'initialise' it.

On Orba 1, you can load a preset, turn it off, turn it on, it loads the preset from flash into RAM, and you can play. If you create a faulty preset by messing with the XML, it will crash and reset when you load it, and start looping, because it's trying to load the same faulty preset and crashes the same way each time. You can fix it by booting from DFU mode and doing a factory restore that resets the presets.

I broke my Orba 2 by opening the partition where the presets are stored and direcly editing the XML of one of them. This puts it into the same kind of loop where it crashes, boots, tries to load the preset into RAM, repeat. But now the storage area where the presets are held can't be restored by any means we've discovered. 

I don't know how you crashed yours, but it presumably started when you loaded a preset that you'd edited.

It's hard to believe that there's no way for Artiphon to recover the device from this state, but they haven't said what it is. If you give up on it entirely it would be interesting to see the PCB.

(I reckon the only way to recover it would be an alternative bootloader that made the data partition accessible without attempting to load a preset. We only have the "run" version of the firmware; we don't have a "diagnostics" version.)

For general reference, the way to access the data partition is to establish a serial connection at 115200 to the Orba using the port shown under the COM ports in Windows device manager and use the command "m". This is what it looks like.

Various other commands available. This is "l".

Proceed with caution with a working Orba. I wasn't able to open a serial connection to my looping one. I experimented with these settings on Orba 1 but I don't dare on Orba 2.

@BJG145 - Ah, your first comment there makes a lot of sense to me. I'm not entirely sure how I bricked the Orba - I had two breakdowns which I recovered from. (Probably how you just described though.) After the second I couldn't do a firmware update that was being pushed on us, but I could get by, by opting not to try and do it again each time I used the Orba connected. I always deleted the offending preset if I could even if I wasn't sure it was guilty.

The final breakdown left it bricked - possibly, in trying to fix it I did the wrong things and made it worse.

In a way, this brings us back to the factory reset issue - I wouldn't have minded wiping my data partition, that was backed up, and in any case I wouldn't have wanted to restore all the presets I had on it anyway. That bit of housekeeping was due anyway. Wiping that partition seems to be a basic facility we should have available. I can't imagine Artiphon don't have a method for doing that themselves - they must have needed it in development.

As an aside, the new Orba I now have would update to 1_1_13 (which panicked me a bit!), but was fine with 1_1_17 and all seems to be well.

I did pay some attention to your posts about song data although I couldn't quite see what your end aims were. What has struck me, as someone who is really bad at dealing with drums (of any sort), it would be really helpful to be able to create drums patterns  with a step editor. Do you think we know enough to create basic patterns as xml that can be  injected into song presets? (I have only used songs as an easy way of switching keys so far.) That would be useful for me, but could be useful for others who simply want beats looping that they can play over to their hearts content. I don't see Artiphon's approach to songs as particularly viable for many. (And don't get me started on stems!)

Login or Signup to post a comment