Start a new topic

Bluetooth connection & Android 13

I had BT connection problems with my Galaxy S22 Ultra with Android 13 from the start: it gave continuous errors and now, after the last upgrade (Firmware 1.0.10, App 1.0.104), my Orba 2 at first seems to connect but eventually not (screenshots attached). 

I allowed all the permissions the app asked for, Location services included.

The USB connection with the smartphone seems to work fine so it should definitely be a BT/Android (or Galaxy?) problem.
Any suggestions or same troubles?



2 people like this idea

Same issue on android 12 for me.

Connected and not connected in the same time.

Reconnecting by bluetooth does not help.

Temporary fixes by powercycling orba2, but happens again in several minutes.

firmware 1.0.11, app 1.0.146

Do we have a fix for this yet, running the app on my Mac is fine but would love to run it on my Note 20 ultra, please fix soon! Keep showing disconnection error button.

1 person likes this

If you are running Android 13, know we are working with Google on a fix.  Several tech companies that use MIDI over BLE (including us) are experiencing these issues.  I know this is frustrating.  It is to us as well but we are working on solutions as quickly as possible.  

1 person likes this

Hello! Is there any updates on this issue? Samsung Galaxy S22 Ultra also.

Thank you!

Hi Really need an update on the status of this issue. Bought this purely to use with my OnePlus Android/Oxygen 13 phone and it doesn't work. This is a very serious problem. Even provide a non Bluetooth solution if that's possible. Thanks

@Britt: I'm hoping the fix will be quick because it's 5 months since I first reported this issue.
I wouldn't see this fixed having Android 14 on my phone...

1 person likes this

We're seeing some positive results with the latest Android Beta.  If you have a newer Pixel phone, you can see if you have an update waiting for the Android 13 OS.  

Colin, in the meantime you can connect to Android devices via USB.  

1 person likes this
Any update to this. I just bought this item this week specifically to use on my commute. It's very annoying to have USB plugged in to the phone. Ready to return this if it can't get resolved! Using OnePlus 10 Android/Oxygen 13.1

1 person likes this
This issue is open nearly a year. It's outrageous to still claim you've been working on this at all or work with Google. This doesnt work in Android 12 and still doesn't work with Android 13. Please provide an update on the work that has been done to resolve this and a roadmap of any future work. If you cannot provide the above then just admit that it doesn't work and won't work, so I can get a full refund.

And it still doesn't work on android 14. 
Maybe its time to provide an super flexy long usb cable with the orba free of charge.

2 people like this
Oh wow, thanks for letting us know. Not working in Android 14. I can only get the USB to work with a PC, it won't work with a phone and therefore the app is completely useless. I've tried/changed all the options for USB and charging etc. it does t work. Can someone who works for Artiphon please reply here with a status update on when the app will be fixed?

>>Maybe its time to provide an super flexy long usb cable with the orba free of charge.


1 person likes this

@Britt: 8 months ago you wrote "We're seeing some positive results with the latest Android Beta". And...? 

1 person likes this
Login or Signup to post a comment