Start a new topic

Unresponsive Orba? Follow these steps

Follow this article for step-by-step instructions.

1 person likes this idea

Mine is out for delivery today.  I guess I will assume that I need to first try and install via standard procedures, and if that does not work, revert to these procedures...I guess

A follow up in case this might help someone else.  I got my Orba today..lots of good things to say about it.  it does a lot that is unique and has even more potential.

Mine installed and firmware updated w. little fuss.  One thing I did notice is that I needed to plug in and start up Orba and open the desktop app (mine is Windows) in the right sequence for things to least I had to do that.  I dont think that is uncommon...after 2 or 3 changes in the sequence, the Orba connected and the firmware update became available and I just had to click on it and things are working.  I dont remember the sequence...what can i say..i;m an old goat...ha

update: that was shortlived.  after connecting it to my android device, Orba is stuck and wont be recognized via usb direct..guess i need to pen a ticket

1 person likes this

Mine is unresponsive, too... I just got it today, did the firmware upgrade, and it just froze up about an hour later.  lights 1,2,3,4 on, nothing works... I went through the FAQ procedure, no luck.    My firmware upload on my iMac said:

11 Sep 2020 10:02:20pm - Downloading Update Info

11 Sep 2020 10:02:20pm - Downloading Updater Utilities

11 Sep 2020 10:02:20pm - Downloading Updater Util - Capsense Bootloader

11 Sep 2020 10:02:20pm - Downloading Updater Util - ESP32

11 Sep 2020 10:02:20pm - Downloading Updater Util - DFU

11 Sep 2020 10:02:20pm - Uploading Firmware

11 Sep 2020 10:02:20pm - Executing: /Users/*********/Library/Artiphon/Orba/UpdateUtilities/dfu-util-mac/dfu-util -l

11 Sep 2020 10:02:20pm - Unable to update - Orba not connected

11 Sep 2020 10:02:20pm - Upload Failed

4 people like this

Yep me too exactly as above.  Sent email to support and we will see.

3 people like this

I left it plugged in overnight, and the next morning it worked fine.  It ran the firmware upgrade, and it seems to be working well now.

1 person likes this

Well its plugged in now I'll see if a miracle happens in the morning.  Thanks.

And its still a brick.

(237 KB)

3 people like this

I just got mine yesterday - Sept 13th. I made sure it got a full charge overnight and verified basic operation. I tried to connect and talk to it using the IOS App first, but it said I needed to update the firmaware. I plugged it into my Mac Mini and downloaded the desktop App and tried to initiate a firmware update. That turned was when locked up. Now I can not power it off or get any response out of it. Green light on 8 and blue light on 1.

So I guess it must be stuck in DFU mode, but none of the recommended procedures are able to unstick it. I need a true hard reset. Hard to believe that this device was designed without the usual pinhole reset button.

Still bricked.  Hoping support will contact me.

2 people like this

I tried to download the firmware but it keeps failing. NO RESPONSE FROM SUPPORT! NONE!

Very disheartening. Anybody got anyway to actually contact support? Verbal? Chat? Email?

Very sorry to hear that. Please contact Artiphon support: At the moment the response time is a bit longer than it should be.

1 person likes this

Same here -- completely died on first attempt to update firmware.  Tried the recommended procedures as shown above, no response, logs indicate unit stuck in DFU mode constantly.

Reset usb-c, turned app on and off several times, held power button down for 10 to 120 secs, no response.

DOA  What a huge disappointment, Artiphon!

4 people like this

Same - first attempt to firmware update, Orba seemed to power off, now wont even power on again (at least, no evidence it is on - no LEDs, sound, nothing showing in app, etc. App wont even let me attempt a firmware update again.

2 people like this
Login or Signup to post a comment