Start a new topic

Unresponsive Orba? Follow these steps

Follow this article for step-by-step instructions.

1 person likes this idea

Got my Orba yesterday, can't connect to my phone or laptop.. recognizes Orba as USB speaker device or something.. driver issue? I hit shift +click on the firmware update in the Desktop App and it runs into a problem, can't get past this screen. My phone app says I need to update the firmware so I can't use it on my phone either! I don't have another device to try this on, just a laptop so now what??

Just after receiving the Orba I connected and updated the device without trouble.. used it for a couple of days and suddenly died and didn't get recognized by Windows anymore.. made my kid (birthday-present) not happy.
I connected the Orba to my Linux-based computer and at least gave some response (lsusb), "STMicroelectronics STM Device in DFU Mode", so at least I knew there was some life in this dead-looking device.
I decided to connect it using another USB-port on the Windows-machine, I believe I pushed vol+/power for 5 seconds and voila.. it connected and update (latest already was installed) went fine.

I think stuff like this should not happen, a brand new device completely dying like this is unacceptable, and this without some obvious, easy to use and functional hard-reset option makes it even worse.

Andrew Wraight's comment (page 4) helped me a lot by the way..

Thanks for sharing this, @Dark! We've seen this solution work as well.

First Orba bricked after trying to update. advised to just replace it. Got my replacment an was scared to update but after playing with it for a bit thought i'd go for it.

mistake. second orba bricked.

I was very excited to get the ORBA but after the firmware update it is no longer responsive. I’ve attempted the fix so many times that my fingers are numb from pressing the buttons. I’m not even sure if it is receiving a charge. Hopefully there is a fix for the rest of us that still has a unresponsive ORBA. sb.

It looks from the screenshot as if your Orba isn't connected. Tap the Orba icon next to the Artiphon logo button at top right to bring up the Bluetooth device list, and then tap Artiphon Orba to connect.


Yup me too - managed to update firware once after much fussing around. Then after around twetnty minutes of use I switched it off and it has since refused to restart - completely dead. Have tried to reinstall firmware but it's unrecognised as a USB device so no joy. Really frustrating. I've logged a support ticket and await a response.

Same here send an email direct to the support email and also thru the support screen.  Including screenshots etc. So far as we say crickets.

Looks like I am joining the increasing list of people with an unresponsive Orba!

It work great for the first seven days then nothing. I tried all the steps suggested by Adam on the support pages to get the Orba to exit DFU mode without any success. It will not turn on, will not charge, will not connect with the app using the cable supplied, nothing. Dead as a Dodo. I am left with a very expensive paperweight.

Support ticket lodged ....

Same here. Send an email to technical support .

I am going to give them a week to at least contact me personally.  New launch and all that and then I am going to involve Kickstarter.

here's the correct way to solve bricked Orba.
I've used anoter PC, as somebody suggested as I couldn't do it on the first PC.
But maybe same PC will be ok after this steps too.

1. get your Orba after over a year of waiting
2. have it bricked in the first week of using :P totally no response, zero LEDs, no sound ;(
3. don't plug your orba to PC yet, install the 0.14.34 orba app
4. press and hold volume +, then press power button too. release buttons (LEDs won't light)
5. plug to the PC. turn on orba app
6. wait for some drivers to be installed (i had that step)

7. if the app says that you should update firmware, click the update button

8. orba will blink it's LEDs for the first time
9. unplug Orba fast

(you should be able to play sounds after this step, but I wanted to try to complete the firmware update
10. connect orba to PC again, open app, you will notice that your orba's battery is loading

11. shift + click on the firmware update button

12. talk amongst yourselves as reccomended :P

13. wait ~2 minutes

14. nailed it! ;)

15. keep your fingers crossed Artiphon will do something really soon to fix this, and that Orba won't get bricked again

16. keep your fingers crossed so that Artiphon will think of a LED blink pattern that could communicate some messages to the owner while pressing some physical buttons to do the hard reset or put the orba into this weird DFU mode.

Connected my Orba to another PC, I was able to reanimate it using the "Holding-Shift" method


Thanks for adding this, I'm glad it worked for you.  Did you get any indication at all when you held the two buttons down, did the lights flash or was any sound emitted from the Orba.  I tried it several times already, but nothing indicates it's been reset.  Thanks!

Yes, if Orba is charged, pressing the power button and the volume down button (-) at the same time for 15 seconds is the hard reset. There is no sound but Orba should power up normally after that.

If it does not, the shift-clicking on the firmware update cloud symbol in the app's settings page is the other way this could be resolved.

Our customer service team currently has a lot of tickets and the responses take longer that they should, we apologize for that.

Login or Signup to post a comment