Start a new topic

Unresponsive Orba? Follow these steps

Follow this article for step-by-step instructions.

1 person likes this idea

Thanks for adding this, I'm glad it worked for you.  Did you get any indication at all when you held the two buttons down, did the lights flash or was any sound emitted from the Orba.  I tried it several times already, but nothing indicates it's been reset.  Thanks!

Yes, if Orba is charged, pressing the power button and the volume down button (-) at the same time for 15 seconds is the hard reset. There is no sound but Orba should power up normally after that.

If it does not, the shift-clicking on the firmware update cloud symbol in the app's settings page is the other way this could be resolved.

Our customer service team currently has a lot of tickets and the responses take longer that they should, we apologize for that.

20 Sep 2020 7:58:40pm - [25586] Failed to execute script artiphon_esp32_programmer

20 Sep 2020 7:58:40pm - Traceback (most recent call last):

20 Sep 2020 7:58:40pm - File "", line 8, in <module>

20 Sep 2020 7:58:40pm - File "/Users/patrick/Documents/Artiphon/esp32-bluetooth/firmware-updater/venv/lib/python3.7/site-packages/PyInstaller/loader/", line 627, in exec_module

20 Sep 2020 7:58:40pm - File "site-packages/serial/", line 29, in <module>

20 Sep 2020 7:58:40pm - File "/Users/patrick/Documents/Artiphon/esp32-bluetooth/firmware-updater/venv/lib/python3.7/site-packages/PyInstaller/loader/", line 627, in exec_module

20 Sep 2020 7:58:40pm - File "site-packages/serial/", line 33, in <module>

20 Sep 2020 7:58:40pm - ImportError: dlopen(/Users/localadmin/Library/Artiphon/Orba/UpdateUtilities/artiphon_esp32_programmer/, 2): Symbol not found: ____chkstk_darwin

20 Sep 2020 7:58:40pm - Referenced from: /Users/localadmin/Library/Artiphon/Orba/UpdateUtilities/artiphon_esp32_programmer/ (which was built for Mac OS X 10.15)

20 Sep 2020 7:58:40pm - Expected in: /usr/lib/libSystem.B.dylib

20 Sep 2020 7:58:40pm - in /Users/localadmin/Library/Artiphon/Orba/UpdateUtilities/artiphon_esp32_programmer/

20 Sep 2020 7:58:40pm - Error Installing update - ESP32

20 Sep 2020 7:58:40pm - Upload Failed

that is all I get when I try to install the FW

I hope you will get this fixed soon. this is all a bit of a disappointment..

Same here except windows 10 machine for me.

I Tried another Windows-PC. Worked for me.
Ok, some good news for a change -- I got my Orba working again.

I decided to try another laptop, removed the virus detection software, in this case, ESet.  It has a very powerful low-level detection mechanism that has blocked other processes on me in the past.

Once I restarted the 2nd macbook, I followed the shift-click firmware update, and it didn't stop dead in its tracks like it did every other time I tried.  Orba app indicated it was updating, spun and spun, and about 3 minutes later, it was done, displaying a message "Nailed it."  Sure enough, the lights came back on.

If you're getting immediate blocks or fails when you're trying to update your firmware, consider this problem.  I know not everyone can disable or safely remove their virus checker, particular Windows users, but this is what worked for me.

I'm wondering if there's a way to download the firmware update only, so that once that's done, users could then disconnect from internet, and only then turn off or remove virus checker.  And then you'd need a way to find the firmware file in your local directory.

Hope this helps, I know all too well how frustrating this is!

Mine just bricked.

I got mine several months ago, have kept firmware up-to-date. Plugged it in last night to charge after about a 45 minute session.

Followed the KB article, submitted an email to Support.

Let's see what happens.

First update attempt resulted in the lights out and unresponsive. Tried all of the button pushing including the three arm method to no avail. The device appears to be not connected to the computer.

Putting the Orba into DFU mode (press - and power for 15 seconds) my Windows 10 computer saw it as "SMTP Bootloader". There was no driver identified to support this. Reinstalling the app didn't resolve the driver problem.

I left the device in DFU mode, installed the Orba app in my laptop, connected the Orba, drivers started to load, the lights came on, the app said it had detected the device in DFU mode and the firmware update started automatically. Now it works.

It appears that somehow the Bootloader driver isn't being installed in some installations to support DFU mode. This probably accounts for the firmware update failure as the app can't see the device without the driver. 

Tried everything. Very disappointing. :( Not able to use. Still no message from the support. 

Don't give up on it just yet; it sounds very much as if the charge simply ran down. How were you charging it for those three hours? Did the app show it as fully charged when you started using it? Try charging it off mains power rather than a computer, give it at least two hours, and check the charge in the app. After charging you might need to do the force-reboot thing (press & hold power and volume-down together for 10 seconds) to bring it out of its trance.

@Jacob Bruner Hellooo!! Now it's working!! I did the same procedure on another computer and it worked !!

Hi Troy. Just responded to your ticket about this. Let me know if you have any other questions. 

I'm literally trying to update my orba on my other computer which has no antivirus beyond windows defender on it. I'm running the Orba app as administrator. The shift-click firmware update seems to have just completed. Orba seems to be working fine now.


I did support two kickstarter projects and won't give my money agin for a kickstarter campaign.

The orba is one of the two campaigns and right now I have a nice piece of paperweight to fix some letters at one place.

Lesson learned.

kickstarter is not for me.

Hi everyone,

We've continued to pin down this problem and revised the step-by-step instructions. We're seeing a lot more success with users. 

If you're still experiencing problems with an unresponsive unit, please follow this article to give it a try. 

If the problem persists, the fastest path to a solution is contacting In these high-volume threads, it's possibly that your question gets lost. 



Login or Signup to post a comment