Start a new topic

Unresponsive Orba? Follow these steps

Follow this article for step-by-step instructions.

1 person likes this idea

There is one step we added in the faq

It is possible that Orba is charged and in DFU mode (update mode, appears unresponsive) but powered off. Pressing the power button before forcing a firmware update by dragging the firmware file onto the cloud symbol in the app settings can resolve that.

And one last thing I did disable my antivirus hold down everything and tried again  Exactly the same as the last X time it reports that it can't find an Orba.

Been there done that have the teeshirt.  But ever hopeful I tried yet again.

17 Sep 2020 12:34:49pm - Downloading Update Info

17 Sep 2020 12:34:49pm - Downloading Updater Utilities

17 Sep 2020 12:34:49pm - Downloading Updater Util - Capsense Bootloader

17 Sep 2020 12:34:49pm - Downloading Updater Util - ESP32

17 Sep 2020 12:34:49pm - Downloading Updater Util - DFU

17 Sep 2020 12:34:49pm - Uploading Firmware

17 Sep 2020 12:34:49pm - Executing: C:\Users\jbrun\AppData\Roaming\Artiphon\Orba\UpdateUtilities\dfu-util-win\dfu-util.exe -l

17 Sep 2020 12:34:50pm - Unable to update - Orba not connected

17 Sep 2020 12:34:50pm - Upload Failed

Well its plugged in now I'll see if a miracle happens in the morning.  Thanks.

I have a MAC and have tried the various different options here to no success.  But hey, did you see we can purchase a protective silicone sleeve for our half round bricks?

I just received it. It worked the first day but now doesn't work, won't turn on and won't charge. Completely unresponsive. A huge waste of money!!!!! Don't buy this and leave reviews everywhere possible.

Hi Destiny.  If you wouldn't mind opening a support ticket, we can resolve the issue by either troubleshooting to revive your Orba or replacing it for you.

Open a ticket here.

Yeah, I would be lying if I said the silicone sleeve announcement didn't rub me the wrong way

Hey Jacob, Paul, and Andrew - I feel your pain, but keep your spirits high. This thing is worth waiting for. Sucks that you may have gotten a lemon but they will get you fixed up. I just closed my own ticket and would urge anyone else on this thread to check and see if you still have an open ticket and close it in order to let tech support get to those in need.

A follow up in case this might help someone else.  I got my Orba today..lots of good things to say about it.  it does a lot that is unique and has even more potential.

Mine installed and firmware updated w. little fuss.  One thing I did notice is that I needed to plug in and start up Orba and open the desktop app (mine is Windows) in the right sequence for things to least I had to do that.  I dont think that is uncommon...after 2 or 3 changes in the sequence, the Orba connected and the firmware update became available and I just had to click on it and things are working.  I dont remember the sequence...what can i say..i;m an old goat...ha

I really enjoyed playing with mine before I tried the update. Totally a cool instrument and can't wait to get it back and functioning!

I am where you seem to be a year ago. Have I not picked it up in that length of time? Anyway I found where someone pressed the on/off + the down volume and it worked at getting my un bricked and it actually completed the firmware update. 

I am not happy - only about a 1/2 hour to figure it out. Many thanks to all that have gone on this mission before me.

Like most of you, I'm one of the original Kickstarter backers of Orba. The rechargeable battery has died. Is a user installed replacement available? How much cost?

Thanks for following up on this @joseph. Just messaged you about your Orba battery! 

I had a hard time, but I recovered safely.

It didn't work when the batteries were completely zero.

The operation while charging did not go well. Let's fully charge it before executing.

However, since the LED does not light up, You cannot confirm whether it is charged or not.

I think you should charge it for about 3 hours.

Login or Signup to post a comment