Start a new topic

Orba Froze/Stuck

Last night in the middle of a nice beat session the orba just froze. i just woke up and its still froze/stuck. pads arent responsive, ive tried holding the power button to get it to shut off or reset to no avail. the red REC led light is on as well as the purple LEAD led light is on too. Im freaking out because ive only had this for 5 days. i updated the firmware soon as i got home from work. sound quality is still distorted and the looper has some hiccups but i would assume that would be fix with more firmware updates. Im now more concern with the fact my orba doesnt function at all anymore please help me. Also, I was using my orba last night with the iOS app bluetooth to it. When loading presets to the orba it always drops BT connection and the preset never syncs to the orba. i would re-connect it thru the orba iOS app and it'll continue to drop BT connection everytime i attempt to push a sound preset to the orba.

same here, any solution?

so what i did was just let the battery die. then I charged it and I was then able to power it on and its been functioning as it should every since.

This happened to me to.  I tried some random things but holding the power button the the (-) volume button together for about 6 seconds seemed to release it.  Or it was just coincidence.

Login or Signup to post a comment