Start a new topic

Issues Connecting to Bluetooth

Just bought this s/h and it wont pair with my android or even show up in bluetooth on my ipd 4 -any suggestions? Thanks


7 people have this problem

Hi there. If you're still having this issue, would you mind reinstalling the firmware.


  1. Reconnect Orba to your Mac or Windows computer via the included USB-C cable
  2. Open the Orba desktop app and go to the settings page
  3. Hold down the shift key on your keyboard while clicking on the update cloud


Let me know if this helps 


1 person likes this
Worked thanks!

1 person likes this

Once upon a time, I was able to connect to Orba app on Android via Bluetooth (and then I had all sorts of other problems), but now I cannot connect anymore. The box just doesn't show any device.


1 person likes this

BTW, on my Mac it's the same...

I just unboxed my new Orba and downloaded the app on iOS 15.0.1. No luck connecting via Bluetooth. Tapping the Bluetooth icon in the upper right corner of the app opens a dialog box which then says connected, but the Bluetooth icon remains grey and at the top of the app it says no device connected. Turning off the Orba causes the dialog box to say offline, so it definitely sees the Orba, but the app isn’t responding to it.

Thanks for following up on this, Andrea. I just sent you an email! Let me know if you have any other questions.

Can't connect orba2 to android? Why? Is it bluetooth after all? If I know this im not sure if I wanted it

Yeah for some reason Bluetooth does not work with my phone. I have an Motorola Moto G6 Plus. Would be nice to see a solution to this bug/problem. I cant use my Orba if I cant change the scales it play.

Have you tried a USB cable with an Orba updated to firmware 0.14.11 and app version 0.14.28?

Arne thanks for a really fast reply - I just tried with USB cable and it works. It is a good workaround for now :)

Google Play only offers version 0.14.21 of the Android app. So how or when will I get update 0.14.23 that will get my BT connection to work?

Still only seeing v. 0.14.21 via my Galaxy S9 - 16 days after Wilfried's post.

Yes Arne Wallbrecher, like Andreas says, the USB connection is a good temporary workaround. This BT problem has been recognized for more than 2 months and several updates ago. When will Artiphon fix the Bluetooth bug? Can't always be tethered to a usb cable. I would appreciate if Artiphon makes this fix a priority.

I have the same problem connecting with the Android app via Bluetooth. The Orba icon in the upper-right corner does nothing. Is there anything I have to do on the Orba itself to make it visible? The On/Off button is also the Bluetooth button. But the manual says nothing about how to use it. Except for turning it on and off, obviously. 

Login or Signup to post a comment