Start a new topic

Received the Orba, wont turn on after firmware update

The Orba arrived this morning, I was able to play with it for a bit before downloading the IOS app and being told to update the firmware. I did and after it completed the Orba will no longer turn on. 


8 people have this problem

I’m not sure what did it but I clicked “exclude process” on that norton screen and tried again and it suddenly came back on and did the firmware update! So either you guys fixed it internally or clicking that button helped!!
Dana, thank you! That is very helpful.

. Orba worked out of the box then I connected to MAC to do the firmware update and now it is useless. Put in a help ticket and tried all of the above tricks to no avail. I am very sad. 


If you tried charging Orba, shift clicking on the firmware update symbol in the Mac app and holding the volume down button and the power button for 15 seconds and this did not work the support team will get you back up and running.

After reading about some people having success today I was hopeful and worked on my Orba again. Unfortunately nothing worked. I added Orba to the exceptions list of my firewall, turned off virus protection, and ran Orba as Administrator. No luck. Still a dead device. I updated my ticket with the information and added the log file. I sure hope they find a solution soon.

@Edo
I'm just a user like you, but I did experience the DFU mode problem.  My Orba recovered nicely with the file and instructions Artiphon provided to me.  I've been playing with it fine for a couple days now, so aside from the updater issue I have had no problems.  I suggest it's still worth playing with, then if you do have any issues, create a ticket on this site and they will help you out as soon as they can.  Better to gain some benefit from the device and possibly have to fix it than gain no benefit because of fear to open the box.

i uninstalled Orba app and did not update. it works fine now

Hi Michael...I agree. It installed fine for me...and I was doing a lot with it problem free until I tried to use it with my Android device which didnt work and now it is in DFU mode after reconnecting it via wired connection...I did the stuff recommended and that didnt work so now i need to open a ticket

I found that if your orba goes totally dark while you're connected to your computer, the "shift+click" update may also fail because the device is off.  Shift+clicking the update cloud will also fail if you're stuck here.  Anyway, this worked for me: 


Close the desktop app after you're sure it has been updated.  While leaving your "dead" orba connected to the usb, hold power button and volume (-) down until you hear it "beep-boop" from windows (it will power off and unrecognize).  Then do it again until you've heard the right beeps when you connect something to windows.  Although the orba is still dark with no lights, you at least have it powered on in windows.


Relaunch the app and try shift+clicking the update cloud again.  Mine launched and work after going through the power recycle sequence.


Hope it helps guys -

Very sorry to hear that. Just double checking, after charging and Orba not turning on, did you try to hold the power button and the volume down button (-) for 15 seconds? If the app doesn’t open after closing the app (swiping up from the bottom of the iPads screen so that you can swipe through the apps, then swiping the Orba app up to close it) the next step could be to delete the app and install it again.

Fixed it (for now)....this kind of reminds me of the early days of windows..opened a ticket but am sure they are swamped..i think they will respond at some point.

Thanks, I’ll pass it on to the support team so they can send a replacement and get the one you have back for examination.
Uninstall the application and reinstall it. Do not update. This woke the Orba back up. IT is working now.

I have tried everything suggested on this thread and none of it resolves the issue. I currently have a paperweight that doesn't turn on. 

Login or Signup to post a comment