Start a new topic

Battery defective, Instrument one will only operate when plug into a power supply!


Your ticket has been created.

#49789 Instrument 1 battery doesn’t charge when connected to power supply!

Instrument 1  battery does not charge when connected to power supply! A green light is present/showing, as if it were fully charged. But instrument 1 does not turn on, when unplugged from power supply!


this is a warranty issue









Order summary

April 17 2021



INSTRUMENT 1 × 1

Black



Discount (ShipItFree!)


Subtotal


Shipping


Total



Drained Battery:

If you press the INSTRUMENT 1’s power button on the I/O panel and the PWR LED does not light up, your instrument’s battery is most likely uncharged. A fully charged instrument's PWR LED light will glow green when powered on. If this isn't the case, connect your instrument to a power source using the included 12V power supply. Please note that using the INSTRUMENT 1 with any other power source can severely damage the unit.


When you connect your INSTRUMENT 1 to a power source the PWR LED should turn blue, indicating that it is charging. You can turn on and play the INSTRUMENT 1 while it continues to charge : )

The problem I’m having with my instrument 1 is presented below:

Other:

If the INSTRUMENT 1's battery still doesn't charge when connected to a power supply and the PWR LED is flashing blue/red, then there may be an issue with the battery itself. If your INSTRUMENT 1 falls under our 1-Year Warranty be sure to submit a ticket to our support team with as much information as you can provide. We'll follow up as soon as we can.

1 Comment

Hi Sally,


Thanks for reaching out. It looks like there was an issue with your INSTRUMENT 1, but I'm seeing that you've already requested a replacement under warranty. Once your INSTRUMENT 1 arrives at our warehouse, we can go ahead and send your replacement unit. Let me know if you have any questions about this. 

Login or Signup to post a comment