Start a new topic

Orba2 android app hangs

I'm running a Samsung A32 with Android 12, and the app simply hangs at startup. I get the screen saying to power on, and the next arrow generally does nothing. If I keep tapping on it, I can get to the connect screen, but it hangs there too.

I've tried reinstall of the app and reboot system, no go.


I generally don't like to add "me too" comments, but I'm having exactly the same problem with the Orba 2 Android app abd Bluetooth connection. I'm using Android 12 on a Samsung Galaxy Z Flip 3, with the most current firmware installed on the Orba 2. The app connected over Bluetooth once- after a very long delay- but after uninstalling and reinstalling the app it's now impossible to connect. I have also observed that the touch mappings of the app's GUI elements are problematic.

Hey Erich, here are a few things to check out.  Hopefully, it will get you paired with your Galaxy Z.  If not, open up a support ticket and we can go from there.

1. Make sure that you’re pairing from within the Orba 2 app rather than from the Bluetooth settings in your device. 

2. Check to make sure that your Galaxy Z isn’t connected to any other Bluetooth devices, like headphones, watches or speakers. Other connections could be interfering with the connection to Orba 

3. For Android Bluetooth to fully pair you must enable location services for the app. If you didn't allow location services when you installed the app, you may need to reinstall it.

One other bit; it depends where/when you connect. Its been a week or so and I forget which was which, but it makes a difference if you connect on the startup screen or from the Orba2 settings menu.

One will say it is connected, but you can't actually upload sounds (the upload page says it is not connected), the other it seems to work fine. I can poke at it later tonight and reply with which way works.

Thanks for reaching out, Lou. This is a known issue caused by the app taking a second to load all of the presets and sample presets that we're looking into. 

Are you trying to connect via Bluetooth or USB, as we've noticed bluetooth takes a little longer? 

In the meantime, we recommend updating to Android 13. The app might take a second to scan presets the first time (about 30 seconds), but you should be good after that. 

I found that if I disconnected all connected Bluetooth devices- including my watch, which I normally always have connected- the app will connect to the Orba 2 exactly once but is very glitchy. It will not connect at all after that, even with all other Bluetooth devices still disconnected.

Unfortunately, without doing something drastic like rooting my phone and installing a new OS on my own, I'm stuck with what the carrier provides. I'm not willing to do that.

I have since determined that the app generally is not hanging. Instead, the problem is the touchscreen coordinate mapping. All touches in this app (and none of my others, so it is definitely not an issue with my phone) need to be 1/4 to 1/2 inch above the actual UI element. If I do that, the app mostly works. The key issue is I am unable to activate any of the UI that is triggered from the title bar - settings, tempo and key change, as touching above these elements is not possible; it is off of the screen.

I am connecting with USB. I've tried Bluetooth, and it doesn't work at all. The initial attempt says connected, but all other areas of the UI, like switching samples, won't let me switch. It says not connected (or something similar) on the button.

Login or Signup to post a comment