Start a new topic

Received the Orba, wont turn on after firmware update

The Orba arrived this morning, I was able to play with it for a bit before downloading the IOS app and being told to update the firmware. I did and after it completed the Orba will no longer turn on. 

8 people have this problem

Thanks for the suggestion, @cynthia, but it didn't work for me. The Orba app still doesn't recognize my Orba.

2 people like this

For windows 10 users. I connected macbook with Orba app then up date my dead Orba.  IT REVIVED !! If you have or use someones macOS device. It's worth trying.

2 people like this

My dead Orba is back with a firmware update on macOS.

The information in this thread was helpful. Thank you.


2 people like this
We are examining this currently but it looks like most cases have something to do with virus scanner and firewall software blocking the actual firmware data and leaving Orba in DFU (update) mode where it looks “bricked”. It’s actually waiting for the data.

2 people like this
To add a little more data; during my attempts to resurrect my Orba I opened my firewall to the Orba program and turned off virus protection.

2 people like this

I honestly don't know how I got it to work, but I ended up unplugging all connected devices and peripherals from my iMac, just to be sure, then contorted my hand to hold down the power button on the Orba, as I held down the shift button on the qwerty while clicking on the firmware update icon in the desktop app. 

Even so, it failed the firmware update, as I continued to hold down the shift and power, though as it was running through a cycle for the first time today, I figured at least the Orba wasn't dead. Then, I did the straightforward firmware update holding down the shift, and it finally had success. 

I think in the end, the app was crashing because of the failed updates earlier - which I still cannot figure out. Moreover, it could be that simply holding down the power button that long helped to reset it (not the combo of power and volume + or -), though whatever the contorted effort, it seemed I definitely had to have the Orba's power engaged, while clicking shift and then the firmware update. 

But it shows up now as updated and working. Nothing personal, but I hope my little stay here is done : ) 

2 people like this

My Obra is turn it dark too with windows10 app when I tried to update and its failed. 

I try to reset by holding down the power and volume(-) buttons. It seems to be powered off. Then I hold power key and it wake up with its device name 'STM Device in DFU mode'. 

But I cannot update firmare via shift key + click on obra app yet. App said 'An error occured during the firmware update'. 

Is there any way to resume my obra? 

2 people like this

mine is completely bricked after trying to update the firmware on windows. it should be fully charged, although led is completely dead now. pressing the power button or power+either volume buttons will cause nothing. shift+clicking cloud icon on app will just display the error. sounds like windows users are trapped, while people who have mac can restore. hoping to see the fix on windows asap.

2 people like this

If Orba is unresponsive and opening the app settings and clicking on the cloud symbol next to "firmware update" does not work, it is worth trying that again. 

Another thing that can work is to:

Press and hold the volume down (-) and the power button for 15 seconds.

2 people like this
Brian, there is nothing changed in updater between versions 0.14.6 and 0.14.8 so I would not expect that to be the cause of any different behavior.

2 people like this

This method fails in the following situations:


9 Sep 2020 3:19:51pm - Downloading Update Info

9 Sep 2020 3:19:51pm - Downloading Updater Utilities

9 Sep 2020 3:19:51pm - Downloading Updater Util - Capsense Bootloader

9 Sep 2020 3:19:51pm - Unable to find extracted utility - Capsense Bootloader

9 Sep 2020 3:19:51pm - Upload Failed

9 Sep 2020 3:19:51pm - Downloading Updater Util - ESP32

9 Sep 2020 3:19:52pm - Unable to find extracted utility - ESP32

9 Sep 2020 3:19:52pm - Upload Failed

9 Sep 2020 3:19:52pm - Downloading Updater Util - DFU

9 Sep 2020 3:19:52pm - Unable to find extracted utility - DFU

9 Sep 2020 3:19:52pm - Upload Failed

9 Sep 2020 3:19:52pm - Uploading Firmware

9 Sep 2020 3:19:52pm - Executing: C:\Users\ilove\AppData\Roaming\Artiphon\Orba\UpdateUtilities\dfu-util-win\dfu-util.exe -l

9 Sep 2020 3:19:52pm - Unable to update - Orba not connected

9 Sep 2020 3:19:52pm - Upload Failed

1 person likes this

just wanted to let everyone know that my device is now back to normal again, after updating the firmware on mac. there is definitely something wrong on windows app. it seems using mac is the only solution for now.

1 person likes this
Hi - disconnect and reconnect doesn’t work on my windows computer. Can someone tell me how to get the log they are requesting? I apologize - I’m not a computer techie!

1 person likes this

Windows 10 User here, bricked Orba after firmware update. I went into my firewall settings and allowed the app manually. I was then able to update the firmware successfully.

1 person likes this
You’re welcome - although I’m not sure how I helped! Lol :-). Hopefully everyone’s starts working soon! :-)

1 person likes this
Login or Signup to post a comment