Start a new topic

Received the Orba, wont turn on after firmware update

The Orba arrived this morning, I was able to play with it for a bit before downloading the IOS app and being told to update the firmware. I did and after it completed the Orba will no longer turn on. 

8 people have this problem

I have tried everything suggested on this thread and none of it resolves the issue. I currently have a paperweight that doesn't turn on. 

have you uninstalled the application, reinstalled without running the firmware? This worked for me on my mac.

i've also been trying this and does not work. please help!!!

Not really looking forward to receiving this anymore. Mine has been in transit for the past 12 days, god only knows where it’s coming from. When it does eventually arrives it seems I have all this crap to look forward to. Disappointing. 

Great to hear!

@Arne Wallbrecher

Hi, I am not a user but I am interested in this issue.

Are you developing in a virtual environment such as Parallels Desktop? It works because the drivers are bridged in the virtual environment. However, in real Windows, it seems that there is a problem because the correct driver is not assigned.

If so, I think it is necessary to develop and distribute an installer that includes the driver on a real Windows machine.

I'm sorry if it's irrelevant.

All the suggestions didn't work until this morning when I decided to try a USB-C / USB-C cable instead of the USB / USB-C cable that came with the Orba. Getting rid of the adapter to plug it in to my MacBook seemed to do the trick.

My only issue is charging now. Been plugged in for days and it still won't turn on unless plugged into power.

What does the battery level in the app show? It sounds as if it may just not have been charging. Do you have something else you can test the supplied cable with to see whether it's working correctly?

It wasn't until this morning that I was able to actually turn it on because of the firmware fiasco. But I did have the Orba plugged in to battery during the time it wouldn't turn on in hopes that by the time the problem was troubleshot it would be ready to go. Evidently it wasn't charging while defunct.

After getting firmware to work it was plugged in to the computer for about 5 hours before I unplugged it. Tried to turn it on and it wouldn't. Just got the flashing red light and then off. So I plugged it into a charger just after commenting earlier. From the phone app it appears to be charging now and almost full. I'll turn it on and off as soon as the Orba cup is full.

I found a solution. I had the exact same problem of RBA going dark during firmware. I found that using a USB-C end to end does not work. Since I have the newer/now-old MacBook, it only had two USB-C ports (grumble). Thus, I needed an adapter. You need to use the cord supplied in the box; USB-C to USB (3). Hope this helps. 

I've sometimes seen that message after the Orba has updated successfully – but not if it's gone dark. A reset while connected to power (press & hold power & volume-up buttons together for five seconds) has always managed to bring it back to life for me, but that was under older firmware and I haven't had the issue with the current version. I notice the Orba manual now says the reset action is "hold power and volume down for five seconds", which may mean either "hold down power and volume" or hold power and volume-down" – it might be worth trying it that way as well while you're waiting for someone who actually knows what they're talking about to get back to you.

Incidentally, Arne's screenshot above shows him running app version 0.14.11, but the current release is indeed 0.14.9 (and the firmware 0.13.19 as shown), so you're definitely on the right version.

I used the latest version of the Mac app today to update the firmware. I got the same error notification that it failed, but it showed as what another user said was the latest FW version (x.13?). I no longer get the "update firmware" message in the app, but there's a new problem. If I connect to the Orba from the iOS app, it just disconnects immediately. I can press the buttons in the app as if it was connected and would work, but nothing does. 

Early adopter times. I kinda wish I'd read this thread about units becoming unresponsive after following the directions in the mobile app, the desktop app not behaving right in as far as updating the firmware. 

Successfully resurrected my orba using the mac desktop app (0.14.6 from the website). The key for me was to not update the desktop app (ignore the update popup) and just go directly to shift + clicking update firmware.

 IF the above doesn't work, I had an ORBA stuck in DFU for a week, and the Firmware Update failed both the base FW ( AND the latest (by shift click), try a different PC.
Not sure why my main Win10 PC didn't load the driver software, but I tried it on my laptop and was finally able to get my ORBA working again.

(PS: I had an open support ticket - no one has responded in the whole week it has been open. Disappointing.)

Here is the following situation: I got it, unpacked it and tried some stuff on my ipad IOS 14 and it worked from the beginning. I could connect via bluetooth and started playing with the strng App. Fine. Then I installed the Mac App as I wanted to change to minor scale and shut off the internal sounds. The app said I should update the firmware. which I did. Got an error but after restarting the app it said the firmware is fine and there was no further need to update again.. After that I could not get any bluetooth connection to work again. I tried the 15 second reset and reinstall FW and after that again an FW update error occured but after restarting the Mac App it again said that the FW was ok. No bluetooth connection is working... fun fact.. as a usb c connected device it still transmits midi.. but that is not what I had in mind.... So buyer beware.. The FW update seems to be instable and rendered my device to be mostly useless.. Which means I had fun for 10 minutes and that's all.. I would be happy to receive a working version or an update that fixes this. regards...
Login or Signup to post a comment