Start a new topic

Received the Orba, wont turn on after firmware update

The Orba arrived this morning, I was able to play with it for a bit before downloading the IOS app and being told to update the firmware. I did and after it completed the Orba will no longer turn on. 

8 people have this problem

Successfully resurrected my orba using the mac desktop app (0.14.6 from the website). The key for me was to not update the desktop app (ignore the update popup) and just go directly to shift + clicking update firmware.

I did not install anti-virus software, Windows Defender SmartScreen, and firewall on Windows 10 with clean installation, but it does not succeed.

Isn't it just an app issue?

1 person likes this

I used the latest version of the Mac app today to update the firmware. I got the same error notification that it failed, but it showed as what another user said was the latest FW version (x.13?). I no longer get the "update firmware" message in the app, but there's a new problem. If I connect to the Orba from the iOS app, it just disconnects immediately. I can press the buttons in the app as if it was connected and would work, but nothing does. 

Early adopter times. I kinda wish I'd read this thread about units becoming unresponsive after following the directions in the mobile app, the desktop app not behaving right in as far as updating the firmware. 

I turned off the firewall and virus software and tried it on three windows, but it does not work at all. I'm disappointed. I don't have a Mac.

1 person likes this
To add a little more data; during my attempts to resurrect my Orba I opened my firewall to the Orba program and turned off virus protection.

2 people like this
We are examining this currently but it looks like most cases have something to do with virus scanner and firewall software blocking the actual firmware data and leaving Orba in DFU (update) mode where it looks “bricked”. It’s actually waiting for the data.

2 people like this
This does not seem to be a driver issue. At least on my machine the Orba is recognized, the driver is loaded, ad it responds to USB events. The error that is getting logged for me is that the app is unable to find any of the three utilities for programming the STM. They are apparently downloaded in a compressed file along with the new firmware. And, when I check the firmware update directory, I see a directory for each of the programming utilities. However they are all empty. For some reason they either did not get downloaded, aren’t in the compressed package, or are not being uncompressed.

1 person likes this

@Arne Wallbrecher

Hi, I am not a user but I am interested in this issue.

Are you developing in a virtual environment such as Parallels Desktop? It works because the drivers are bridged in the virtual environment. However, in real Windows, it seems that there is a problem because the correct driver is not assigned.

If so, I think it is necessary to develop and distribute an installer that includes the driver on a real Windows machine.

I'm sorry if it's irrelevant.

My dead Orba is back with a firmware update on macOS.

The information in this thread was helpful. Thank you.


2 people like this

Not really looking forward to receiving this anymore. Mine has been in transit for the past 12 days, god only knows where it’s coming from. When it does eventually arrives it seems I have all this crap to look forward to. Disappointing. 

For windows 10 users. I connected macbook with Orba app then up date my dead Orba.  IT REVIVED !! If you have or use someones macOS device. It's worth trying.

2 people like this

Thanks for the suggestion, @cynthia, but it didn't work for me. The Orba app still doesn't recognize my Orba.

2 people like this
Uninstall the application and reinstall it. Do not update. This woke the Orba back up. IT is working now.
I also have done embedded development for many years and agree with @Michael Peters. In the world of Windows 10 it is impossible to test with every possible configuration. Mac is a much more buttoned-up world without many possible configuration options. Using myself as an example; my computer is one I custom-built with a variety of off-the-shelf components. I doubt Microsoft or Artiphon have ever seen anything with this particular configuration. And the DFU mode means the embedded processor is waiting for code to be loaded. It is not dead. Once the guys at Artiphon figure out the communication issue we will be back in business. I have faith.

4 people like this

FWIW I'm an embedded systems developer familiar with the STM32Fxxx microcontroller family.  DFU mode is definitely not a complete bricking.  From what the logs tell me, they're in an embarrassing spot for sure, but it should be simple enough to resolve.  It just takes time is all.  Give them a couple weeks before throwing in the towel eh?

4 people like this
Login or Signup to post a comment