Start a new topic

Bluetooth connectivity issues with Android App

 Hey there,

after receiving my Orba I tried to connect the device with my Android smartphone. But the direct connection failed. After a lot of google research, I figured out I had to do the connection within the App. But my Orba is not recognized/shown there... only in Android Bluetooth menu. (latest app version [0.14.21] and Firmware are installed.

I tried the connection with the iOS App on a iPhone, where it worked fine.

So my question... Are there any other guys who have the same problem? Is it possible for someone to connect the Orba with an Android device via Bluetooth?


Thanks a lot

Rob


2 people have this problem

The only way I've been able to connect to the Orba 2 using the Android app is to toggle Bluetooth off/on in the phone's (Galaxy Z Flip 3, Android 12) system settings, then launch the Orba 2 app. The Orba 2 should then be listed in the Bluetooth connection window in the app. 


The iPad OS version of the Orba 2 app connects flawlessly the first time, with none of the hoop-jumping required with the Android app.

Found that Bluetooth to Orba from the Android app does not work at all for me. What I did discover however is that after many unsuccessful attempts of connecting via USB to Android is to get it working I had to go in to Android settings and enable OTG connection. Once that option was turned on all worked well. Hope this may help someone

I also came to find out about the app disconnecting every time I try to load a preset. Android user, galaxy s9. The app seems very unstable and constantly disconnects. No presets at all are available, sooo... Just kinda stuck using the built-in sounds. Hire some developers, guys!! Your product WILL fail unless you get these basic features solved, and quickly! I sure hope you do, as I love the concept of this device :)

1 person likes this

Just purchased and android app is useless due to constant disconnecting. This thing getting returned in a week if no updates as it seems like this has been an issue for months. 


It disconnects 95% of the time before a new patch is able to load. Can always successfully connect through the app, but either immediately disconnects or starts to load a new sound eternally and then disconnects.


Also pitch bending info is not recorded in my loops. Not sure if thats a bug or a "feature"


Info:

Galaxy 10 running Android 10

App Version .14.27

Firmware on orba updated .14.8

Earlier I connected the Orba to my Mac via bluetooth and used it successfully with Logic Pro X 10.6


Now, I'm using an LG K30 phone and Bluetooth Commander 6.2. I can get the Orba connected as a BLE device.  In this mode, I can select a Characteristic and see the BT data coming from the Orba.


Settings->Connected devices->Bluetooth sees the Orba as an available device, but when I try to pair it, the connection silently fails.


Connected to Mac via USB, opened Orba.app.  Set connection to USB mode.

Disconnected from Mac.

Verified Orba disconnected from Bluetooth Commander.

Settings->Connected devices->Bluetooth->Pair silently fails


I have no USB-c <-> USB Micro-B cable available, so I tried connecting the K30 and Orba to a USB hub.  Set connection mode to USB but no connection made.  Expected to see serial number and firmware version in Settings panel.


Hope this helps.

Without a bluetooth connection and without the ability to save, load and export songs, it is a toy. A beautifully designed toy, though. Very sad that Artiphon doesn't get the software working properly after such a long time.

Yeah. I have a Google pixel 3 and the app disconnects after loading a preset. Love the product anyway.

1 person likes this
hello, i have the same problems, difficulties in pairing between android and orba, when i get the orba app it's always losing connection and i can't load presets. help me please

1 person likes this

The answer is: Activate "location" in android settings, then the orba will be found in the app. You casn even transmit some presets, but the connection is lost after the first acitivity and then has to be restarted

@ M Soulier: The problem with location service on android devices is the fact, that it's theoretically possible to get informations about your location via bluetooth. To make sure, no location information can leave your phone when location service is disabled, some of the bluetooth functionalities are disabled as well. Because the Orba app needs enabled location for bluetooth, does not necessarily mean the app uses the location of your smartphone....

See here: https://android.stackexchange.com/questions/160479/why-do-i-need-to-turn-on-location-services-to-pair-with-a-bluetooth-device


@Andrea: That sounds like the exact same problem I have with my Orba. But like I said, think there will come an update, since we are not the only ones with this struggle.

Look here: https://artiphon.freshdesk.com/support/discussions/topics/44001012370

My problem now is that it connects to the app, but then it fails to upload presets and it keeps disconnecting every time...


1 person likes this

But why does the app need permission for location? What does that have to do with anything?

I had the same problem. When I tapped the Orba icon in the upper-right corner I didn't even get to see a window or list at all. Now I re-installed, and gave permission. Now I see the window "Bluetooth MIDI Devices", but it is empty. My Orba is not there. 

Apparently, it's solved in Orba app v0.14.21I've just tried.

Reinstalled the app, still no permission box shown at startup.

I manually gave the permission to access device location, but nothing.

Hey there,

I've got this massage from Artiphon Support:

'Hi Robert,

Thanks for reaching out about this.  This is a known issue with pairing to Android.  Some artists can connect with no problems, while others can't connect at all.  We're working on a fix for this so thanks for asking about it and being patient.  

 

There are three possible issues here.
1- Orba is accidentally pairing with something else in your home.
2- When you opened the app for the 1st time, you denied access to Orba’s location. In this case you can delete the app and reinstall, or give your app permission to use location data.
3- There could be a new bug in the app, which we are looking into.  If this is the case, you can expect improvements to pairing in the next update to the Android Beta.'


I think the second one was the problem in my case! :D @Jdg, maybe it helps you as well...


But now I have the same problem like many other people that its almost impossible to change presets, because the Orba losts connection after some time again and again. Especially if I try to load another preset. In 98% the app loads the preset and the Orba disconnects. After reconnecting its the same preset as before.

But in fact that there are so many guys with this issue, I think there will comin a patch very soon.


3 people like this
Login or Signup to post a comment