Start a new topic

Audio drop while changing between modes (drum/bass/chord/lead)

Hi I'm happy that I finally received my Orba! The device it's looking great though I can see there are some things that can be improved in the software side.


At this time for me the most annoying issue is some kind of audio drop when changing between modes while a loop is being played or recorded. It's like all the current playing layer sounds are stopped when changing the mode.


Also, I often experience a device reset after switching between modes while playing.


The playability experience is highly reduced without fluidness. I hope this can be fixed in future firmwares.


3 people have this problem

Hi Joan,


Thanks for reaching out about this. Glad to hear you received your Orba! 


Because the looper is a midi looper and midi sends "note on" and "note off" messages, Orba ends all notes when changing modes to avoid stuck notes between different channels. When you listen back to the loop, you shouldn't hear any drops in the audio. 


The second issue you're having is a known issue that we're working on improving with each firmware update, so please check you're on the latest firmware update.

Hi Evan, Thanks for the clarification. It seems to me though that there can be a way to make this work. I understand that being MIDI, a note off must be sent before changing mode if it’s currently recording to prevent stuck notes. But only notes currently played at the time the user changes the mode should be stopped and also only those from the current mode. It seems to me that now all notes from all modes are stopped. But in other cases the mode could be changed without having to force any note off. For instance, if there’s already a recording loop for each mode but the user only presses the A button (no additional notes) it should be possible to change the mode without stopping any playing note because their note-off counterpart will be already recorded in the loop. Another scenario, in case the user is playing a note and simultaneously the A button is pressed then the note off with the previous channel could be sent anyway when the user releases that note (with the previous mode channel) while the next new note would go to the new mode’s channel. I hope this helps in some way and some workaround can be implemented eventually. Thanks!

This is a little problem, yes. And in the "Orba Video Course" there is not this problem audible when switching modes in a live session, so it's a little fake or a "feature" of the lasts firmwares

Seems like sound dropping when switching instruments is still present on Orba 2, and that kind of annoying when trying to play  live  and build something from the scratch. 

It is not all about one loop playing correctly, it is about the performance as a whole.  




1 person likes this
Login or Signup to post a comment