Start a new topic

Received the Orba, wont turn on after firmware update

The Orba arrived this morning, I was able to play with it for a bit before downloading the IOS app and being told to update the firmware. I did and after it completed the Orba will no longer turn on. 

8 people have this problem

After reading about some people having success today I was hopeful and worked on my Orba again. Unfortunately nothing worked. I added Orba to the exceptions list of my firewall, turned off virus protection, and ran Orba as Administrator. No luck. Still a dead device. I updated my ticket with the information and added the log file. I sure hope they find a solution soon.

Thank you, Ken! We are currently working on a fix and we will make that everyone affected gets back up and running.

7 people like this
Same problem here. Windows10 pc after update software. Orba doesn’t work anymore... I tried all approach of this discussion.

2 people like this

I haved a same problem.When Update firmware on Windows10 pc, 

Orba doesn’t work at all.


Orba recognizes as STM Boot Loader in Device manager on Windows10.

( I had change STM32 BOOTLOADER driver to WinUSB driver by Zadig.



But it can not recognise by Orba APP in Windows10.

1 person likes this
i uninstalled Orba app and did not update. it works fine now

I found that if your orba goes totally dark while you're connected to your computer, the "shift+click" update may also fail because the device is off.  Shift+clicking the update cloud will also fail if you're stuck here.  Anyway, this worked for me: 

Close the desktop app after you're sure it has been updated.  While leaving your "dead" orba connected to the usb, hold power button and volume (-) down until you hear it "beep-boop" from windows (it will power off and unrecognize).  Then do it again until you've heard the right beeps when you connect something to windows.  Although the orba is still dark with no lights, you at least have it powered on in windows.

Relaunch the app and try shift+clicking the update cloud again.  Mine launched and work after going through the power recycle sequence.

Hope it helps guys -

@joe Ferguson, no luck for me. To be honest that's about the (at least) tenth time I tried a power cycle. The fact that some methods work for some people but not for others, while other methods work for another group of people makes me think that there are multiple problems occurring here. Unfortunately, I don't think anything that is proposed here on the forums will be a general fix that gets everyone up and running.

Thanks for the suggestion.

3 people like this

Received my Orba yesterday (9/5) unboxed it (created a video and all, was so excited) played with it, then connected to my MacBook Pro and downloaded the app which updated as soon as I opened it. Once the app updated I began the firmware update. It went through the process and showed successful. I played around with it, then downloaded the app on my iPad. I FINALLY was able to connect it via bluetooth and then I created a song which wasn't much really but enough to try it out to see how it would perform. It worked just as it was supposed to. I then tried to save the song and the app locked up and finally crashed. Now if I try to open the app on my iPad it locks up immediately and is non-functional. What's worse is after turning my Orba off last night and packing it up in the Travel Case, I grab it this morning, take it out of the case and..., dead. Wha? Ok, so let's try charging it. Two hours later Orba still won't turn on. Try the steps given here and nothing. I now have a black brick that resembles a sliced grapefruit. Wow, talk about the proverbial "flash in the pan," geez. I do realize that essentially we are the beta testers for any product offered through the crowdfunding process, but damn. I don't know what's worse, getting beat by a creator and never receiving the backer reward or receiving a backer reward and it turning into a brick less that 24 hours later. What makes it even worse is having to check back here every few hours to see if someone has found a fix. I think the fix is a new firmware update and free replacement of bricked Orbas. Unless someone can find a way to get them turned on that is. Right now though nothing works, not the app, not the Orba. Both are currently buggy, dead, and useless. I'll just box it up and set it on a shelf for a few months and then try it again. Maybe Artiphon will have it all fixed by Christmas. As it is now though it's more suited for the trash bin than a shelf.

1 person likes this
Very sorry to hear that. Just double checking, after charging and Orba not turning on, did you try to hold the power button and the volume down button (-) for 15 seconds? If the app doesn’t open after closing the app (swiping up from the bottom of the iPads screen so that you can swipe through the apps, then swiping the Orba app up to close it) the next step could be to delete the app and install it again.
Arne, it’s bricked it’s done. Won’t charge, won’t turn on, nothing. Firmware update bricked it. Anytime a device reaches this point there’s not much chance to ever recover it, period. That statement comes from years of experience in the IT industry. It was a fun toy while it lasted but I really don’t see it ever being revived without having to send it back to you guys. It would be different if a light came on when I plugged the USB cable into it but it doesn’t even do that. Absolutely nothing. Only fix is a replacement. You guys should have my info so you should be able to send me one as soon as all backer rewards have shipped. I do think you guys should also refund my $8 for expedited shipping being as how it didn’t even survive 24 hours after delivery. But seriously this is unacceptable, inexcusable, and seriously unprofessional for a company to release an update that gives so much trouble to users and bricks others devices. Was it even tested before releasing it? Was the app tested before releasing it? It honestly doesn’t appear to have been. Again, this is completely unacceptable, inexcusable, and unprofessional. If anyone at your company honestly wants to help you guys have my contact information. Other than that I’ve already boxed up the Orba and tossed it in the closet. I might check back here in a few months or I may just forget about the damned thing altogether and then it might get discovered when my estate gets sold off after my death. Dunno but I’m getting tired of tossing money to dreamers on Kickstarter and receiving overpriced crap. Good luck. I think y’all are going to need it. Seems too many of these things aren’t good for anything anymore except target practice.

1 person likes this
Thanks, I’ll pass it on to the support team so they can send a replacement and get the one you have back for examination.

FWIW I'm an embedded systems developer familiar with the STM32Fxxx microcontroller family.  DFU mode is definitely not a complete bricking.  From what the logs tell me, they're in an embarrassing spot for sure, but it should be simple enough to resolve.  It just takes time is all.  Give them a couple weeks before throwing in the towel eh?

4 people like this
I also have done embedded development for many years and agree with @Michael Peters. In the world of Windows 10 it is impossible to test with every possible configuration. Mac is a much more buttoned-up world without many possible configuration options. Using myself as an example; my computer is one I custom-built with a variety of off-the-shelf components. I doubt Microsoft or Artiphon have ever seen anything with this particular configuration. And the DFU mode means the embedded processor is waiting for code to be loaded. It is not dead. Once the guys at Artiphon figure out the communication issue we will be back in business. I have faith.

4 people like this
Uninstall the application and reinstall it. Do not update. This woke the Orba back up. IT is working now.

Thanks for the suggestion, @cynthia, but it didn't work for me. The Orba app still doesn't recognize my Orba.

2 people like this
Login or Signup to post a comment