Start a new topic

Received the Orba, wont turn on after firmware update

The Orba arrived this morning, I was able to play with it for a bit before downloading the IOS app and being told to update the firmware. I did and after it completed the Orba will no longer turn on. 

8 people have this problem

For windows 10 users. I connected macbook with Orba app then up date my dead Orba.  IT REVIVED !! If you have or use someones macOS device. It's worth trying.

2 people like this

Not really looking forward to receiving this anymore. Mine has been in transit for the past 12 days, god only knows where it’s coming from. When it does eventually arrives it seems I have all this crap to look forward to. Disappointing. 

My dead Orba is back with a firmware update on macOS.

The information in this thread was helpful. Thank you.


2 people like this

@Arne Wallbrecher

Hi, I am not a user but I am interested in this issue.

Are you developing in a virtual environment such as Parallels Desktop? It works because the drivers are bridged in the virtual environment. However, in real Windows, it seems that there is a problem because the correct driver is not assigned.

If so, I think it is necessary to develop and distribute an installer that includes the driver on a real Windows machine.

I'm sorry if it's irrelevant.

This does not seem to be a driver issue. At least on my machine the Orba is recognized, the driver is loaded, ad it responds to USB events. The error that is getting logged for me is that the app is unable to find any of the three utilities for programming the STM. They are apparently downloaded in a compressed file along with the new firmware. And, when I check the firmware update directory, I see a directory for each of the programming utilities. However they are all empty. For some reason they either did not get downloaded, aren’t in the compressed package, or are not being uncompressed.

1 person likes this
We are examining this currently but it looks like most cases have something to do with virus scanner and firewall software blocking the actual firmware data and leaving Orba in DFU (update) mode where it looks “bricked”. It’s actually waiting for the data.

2 people like this
To add a little more data; during my attempts to resurrect my Orba I opened my firewall to the Orba program and turned off virus protection.

2 people like this

I turned off the firewall and virus software and tried it on three windows, but it does not work at all. I'm disappointed. I don't have a Mac.

1 person likes this

I used the latest version of the Mac app today to update the firmware. I got the same error notification that it failed, but it showed as what another user said was the latest FW version (x.13?). I no longer get the "update firmware" message in the app, but there's a new problem. If I connect to the Orba from the iOS app, it just disconnects immediately. I can press the buttons in the app as if it was connected and would work, but nothing does. 

Early adopter times. I kinda wish I'd read this thread about units becoming unresponsive after following the directions in the mobile app, the desktop app not behaving right in as far as updating the firmware. 

I did not install anti-virus software, Windows Defender SmartScreen, and firewall on Windows 10 with clean installation, but it does not succeed.

Isn't it just an app issue?

1 person likes this

Successfully resurrected my orba using the mac desktop app (0.14.6 from the website). The key for me was to not update the desktop app (ignore the update popup) and just go directly to shift + clicking update firmware.


And on the 3rd day it arose...

Lord have mercy, it has been a stressful 3 days I tell ya.At one point I was even considering an attempt at opening it up but decided I'd let someone else be the first to do that. I have tried reviving it on 2 different Macs and a Win10 machine as well. Nada. It never even showed up on either of my Macs as being connected. The Win10 machine did..., once. I've uninstalled and reinstalled the app on both Macs and on the Win10 machine, updated, not updated, and still nothing. 

Today (and I have no clue what the difference in today and the past 2 are but...,) it showed up again on the Win10 machine. Oh wow! I downloaded the app and nope. not gonna do it. *sigh* Ok, one last try with my iMac. Turn on my iMac and plug up the Orba. Holy shit, it's now showing up when I look at the USB connections. OMG! I then downloaded the Orba app and installed it. I did not update the app but gave the firmware update a try with Shift+click on "firmware update". To my amazement I didn't get the error I had been getting so I just sat and waited. About 5 minutes late the update successful message popped up. It's now back to life, FINALLY! But geez people, I have been so frustrated with this thing I did think about just tossing it in the trash at one point and just accepting I'd thrown money down the drain again. Dunno, it still may be the result I end up with in the long run but for the moment it does seem to be alive again.

The trick it would appear is to connect the Orba first then download and install the app. I'm still not confident this thing isn't going to lock up like that again though. Unnerving to say the least.

1 person likes this

That's good news Gary.  Hopefully they get the rest of us up and going soon with a process that's less reliant on randomness.  Fortunately the Orba is based on hardware that is tolerant of software issues.  It's really a relatively solid design.  They just need to iron out some software issues (several, it would seem).  

Unfortunately I don't have a mac at my disposal here, and both of my Windows PCs, which don't use any antivirus or security software that's not built into Windows, fail in the same way:  App fails to download the firmware update, then leaves the hardware in DFU mode.

Hopefully future versions first make sure they actually have the proper software before putting the hardware into programming mode.

I'm out of ideas for my own situation.  At this point all I can do is wait for somebody to answer my support request.

1 person likes this

@Michael, I'm in the same situation. I don't have access to a Macintosh and I've tried every combination of plugging, re-plugging, resetting, charging, and manipulating Windows' firewall and anti-virus that has been mentioned here and a few that I thought of on my own. Nothing has worked. Like you I've fallen back to the position of "sit and wait and hope that the Artiphon guys come up with a solution in the near future."

I assume you'all tried getting Orba connected and firmware updated using your different usb ports? a 2.0? 3.0? powered? unpowered? looked for error messages within windows device manager pertaining to usb ports?  i know zero about apple stuff. I;ve seen poorly designed firmware updaters fail in some ports, but not in others, and in some machines but not in others.  I have an audio interface that is like that.

Login or Signup to post a comment