Start a new topic

Received the Orba, wont turn on after firmware update

The Orba arrived this morning, I was able to play with it for a bit before downloading the IOS app and being told to update the firmware. I did and after it completed the Orba will no longer turn on. 

8 people have this problem

If Orba is unresponsive and opening the app settings and clicking on the cloud symbol next to "firmware update" does not work, it is worth trying that again. 

Another thing that can work is to:

Press and hold the volume down (-) and the power button for 15 seconds.

2 people like this

I was able to un-brick my Orba using the the Mac app. You need to plug it in and wait. There is definitely something wrong with the Windows version of the app. Good luck! Now off to make some noise. :)

1 person likes this

and I can see my plugged obra on device manager as "STM32 Bootloader". good to confirm it's not completely bricked, at least.

1 person likes this

mine is completely bricked after trying to update the firmware on windows. it should be fully charged, although led is completely dead now. pressing the power button or power+either volume buttons will cause nothing. shift+clicking cloud icon on app will just display the error. sounds like windows users are trapped, while people who have mac can restore. hoping to see the fix on windows asap.

2 people like this

My Obra is turn it dark too with windows10 app when I tried to update and its failed. 

I try to reset by holding down the power and volume(-) buttons. It seems to be powered off. Then I hold power key and it wake up with its device name 'STM Device in DFU mode'. 

But I cannot update firmare via shift key + click on obra app yet. App said 'An error occured during the firmware update'. 

Is there any way to resume my obra? 

2 people like this
You can force a reset by holding down the power and volume buttons at the same time for five seconds.
My ORBA is turn it dark too. Use Win10, try to update but failed with error. Then ORBA no response push any button. I want to know how to turn it back on.

Windows 10 Orba app. I received my yesterday. Played with it a bit then downloaded the Orba app. Attached the Orba via USB and opened the app. I was told to update the firmware. So I did. Now the Orba is not turning on and is not recognized by the Orba app. Now reading others have had a similar issue. I have a Mac at work and will try the iOS version tomorrow. Any help will be appreciated.

Addendum: I just went to watch tutorials via the desktop app, and when closing it unexpectedly quit. At least on my system, the Orba app has issues. 

I honestly don't know how I got it to work, but I ended up unplugging all connected devices and peripherals from my iMac, just to be sure, then contorted my hand to hold down the power button on the Orba, as I held down the shift button on the qwerty while clicking on the firmware update icon in the desktop app. 

Even so, it failed the firmware update, as I continued to hold down the shift and power, though as it was running through a cycle for the first time today, I figured at least the Orba wasn't dead. Then, I did the straightforward firmware update holding down the shift, and it finally had success. 

I think in the end, the app was crashing because of the failed updates earlier - which I still cannot figure out. Moreover, it could be that simply holding down the power button that long helped to reset it (not the combo of power and volume + or -), though whatever the contorted effort, it seemed I definitely had to have the Orba's power engaged, while clicking shift and then the firmware update. 

But it shows up now as updated and working. Nothing personal, but I hope my little stay here is done : ) 

2 people like this

I was able to revive it by updating the firmware on a Mac instead of windows.!

1 person likes this

My orba app closed while it was performing a firmware update and now my orba will not light up either.  I do hear the windows chime when connecting it to the computer, but it wont turn on.  I've tried the suggested Shift+Click firmware update but it just keeps saying "and error has occured".

8 people like this

Hmm. I'm stumped, but this does sound like an issue to which someone from Artiphon will have an answer when they're able to catch breath. I expect they're already on this, but it would be good to have a Troubleshooting section in the FAQs for issues like this that seem to be encountered by multiple users, even (or particularly) if the fix is a simple one.

1 person likes this

I should have mentioned that I tried various combinations of holding power/volume to try and reset, per both the manual, and then after seeing Nick's input. 

1 person likes this

I've sometimes seen that message after the Orba has updated successfully – but not if it's gone dark. A reset while connected to power (press & hold power & volume-up buttons together for five seconds) has always managed to bring it back to life for me, but that was under older firmware and I haven't had the issue with the current version. I notice the Orba manual now says the reset action is "hold power and volume down for five seconds", which may mean either "hold down power and volume" or hold power and volume-down" – it might be worth trying it that way as well while you're waiting for someone who actually knows what they're talking about to get back to you.

Incidentally, Arne's screenshot above shows him running app version 0.14.11, but the current release is indeed 0.14.9 (and the firmware 0.13.19 as shown), so you're definitely on the right version.

Login or Signup to post a comment