Start a new topic

Iphone 11 and orba app bluetooth issues

So I received my orba.. I downloaded the app on my phone and tried connecting via bluetooth on the app. It finds my orba and says “connected” but up top on the home screen of the app it still says “no device connected” even though when i go into the actual bluetooth section of the app it says connected. A notification kept popping up telling me i needed a software update. I followed the steps for that.. hooked it up to my computer and tried to update. HOWEVER my computer, which is a macbook, will not read that there is any sort of connection via cable. Did I get a dud orba? It wont work via bluetooth nor will it work via micro usb connection. Im super upset and annoyed right because trying to use this orba without an app is impossible. Its totally unresponsive to me trying to record, switch instruments, change tempos etc. it has a mind of its own.
1 Comment

Hey Elijdob. 


The cable for Orba should be a USB-C cable, not Micro USB.  Do you have a different cable you could try?


We've seen this happen a few times (bluetooth is connected but the main interface says "No Device").  If you reinstall Orba's firmware, that should do the trick.  

  1. Reconnect Orba to your Mac or Windows computer via the included USB-C cable
  2. Open the Orba desktop app and go to the settings page
  3. Hold down the shift key on your keyboard while clicking on the update cloud

If the issue persists, open up a support ticket and we can go from there.

Login or Signup to post a comment