Start a new topic

Received the Orba, wont turn on after firmware update

The Orba arrived this morning, I was able to play with it for a bit before downloading the IOS app and being told to update the firmware. I did and after it completed the Orba will no longer turn on. 

8 people have this problem

This morning (in Japan), I have found that artiphon has released newer version of Orba app for Windows (0.14.13) so that I updated the app and connected my dead Orba to my pc. 

With a few try of updating Firmware with shift clicking update cloud icon on the app, my Orba revived finally!


The desktop app shows the serial number of my Orba, firmware version (0.13.19) and App version (0.14.13) described as above. 

I appreciate very much to the tech support team for their hard work!

Best regards,

3 people like this

The update from Jeremy 4 days ago worked for me! Many thanks!

Here is the following situation: I got it, unpacked it and tried some stuff on my ipad IOS 14 and it worked from the beginning. I could connect via bluetooth and started playing with the strng App. Fine. Then I installed the Mac App as I wanted to change to minor scale and shut off the internal sounds. The app said I should update the firmware. which I did. Got an error but after restarting the app it said the firmware is fine and there was no further need to update again.. After that I could not get any bluetooth connection to work again. I tried the 15 second reset and reinstall FW and after that again an FW update error occured but after restarting the Mac App it again said that the FW was ok. No bluetooth connection is working... fun fact.. as a usb c connected device it still transmits midi.. but that is not what I had in mind.... So buyer beware.. The FW update seems to be instable and rendered my device to be mostly useless.. Which means I had fun for 10 minutes and that's all.. I would be happy to receive a working version or an update that fixes this. regards...


I tried the procedure, pressing the shift key while clicking on the symbol indicated, it seems to resume but always the same update error.

I attach photos

1 person likes this

ok i solved.

i used windows and everything went well.

before i used a mac

Hi all!

I ended up here after I bricked my Orba by doing a firmware update, right after receiving it. This all happened using Mac. 
After trying all the suggestions from Arthipon's guide + what was written here at the forum, I ended up trying a last resort. I downloaded Orba's app for windows, and connected the Orba to a windows machine. This solved the problem, I had to do a forced update: f the above procedure does not work: 

  1. Reconnect Orba to your Mac or Windows computer via the included USB-C cable.

  2. Press and hold the Power button and Volume Down (-) button simultaneously for 15 seconds (you won't see any visual feedback from Orba). This forces Orba to power off.

  3. Press Volume Up, then press the Power button. This forces Orba to enter update mode.

  4. Download this firmware file (you don't need to unzip it)

  5. Drag the file on to the Firmware Update cloud icon in the settings panel of the Orba app (you may need to restart the app for this to work).

 IF the above doesn't work, I had an ORBA stuck in DFU for a week, and the Firmware Update failed both the base FW ( AND the latest (by shift click), try a different PC.
Not sure why my main Win10 PC didn't load the driver software, but I tried it on my laptop and was finally able to get my ORBA working again.

(PS: I had an open support ticket - no one has responded in the whole week it has been open. Disappointing.)

I found a solution. I had the exact same problem of RBA going dark during firmware. I found that using a USB-C end to end does not work. Since I have the newer/now-old MacBook, it only had two USB-C ports (grumble). Thus, I needed an adapter. You need to use the cord supplied in the box; USB-C to USB (3). Hope this helps. 

Received Orba 2 and played with a bit very fun then connected to Mac and it lit up blue and green lights and won’t power off. Tried + and power and - but nothing. The app on computer says USB but most of settings are dark including firmware update.

Try holding Vol- and Power until it powers down.. Then turn on regularly. Does it go back to the Blue lights pattern?

Once it ran out of battery I was able to reset it :)

Login or Signup to post a comment